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Call for Parts, Service, or Pallet 
Pick-up Solutions Guide

Equipment

Guide Features and Benefits
CALL FOR PARTS/SERVICE/PALLET PICK-UP Up to 18 work stations using a K70 touch can have a single call for parts, service, pallet pickup, etc.

CALL RESPONSE Up to 6 sets of three Q120 6-button boxes can be used to respond to requests; Each set can be placed on a 
forklifts/Hi-Lo

EVENT COUNTERS Count the number of times each station sends a request

REQUEST AND ACKNOWLEDGE TIME Total length of request time and time to acknowledge requests are tracked for each station

REMOTE MASTER LIGHT Use a master light to show combined status of all light modules

SMS TEXT/EMAIL ALERTS Generate SMS text and/or email alerts based on specific events

EFFICIENCY METRICS Produce efficiency metrics with provided data 

CLOUD MONITORING Push data to Cloud Webserver or PLC (via LAN or Cellular connection) for remote viewing, alerting, and 
logging.

Increase production efficiency by developing a wireless call-for-parts/service/pallet pick-up system that allows for up to 18 work stations 
to call out to six forklifts/Hi-Los using the EZ-Light K70 Touch to Q120 six-button boxes. This provides for quicker responses from forklift 
drivers and/or supervisors to indicate a request has been accepted. When creating a call system using wireless indicators, work stations 
can maintain a steady workflow and resolve critical issues quickly.

Total time of requests, number of requests, and total time to acknowledge requests are tracked, allowing analysis of average delivery 
and acknowledgement times for each station. Each station has a single call (K70 Touch) with a lighted response that is initially red upon 
request and becomes green after it is acknowledged by the Q120 six-button box. 

On the six-button boxes, each station has a corresponding button that flashes red above the button when a request is made. To 
accommodate up to 18 stations, three sets of boxes per forklift are used, for a total of 18 buttons. When the corresponding button is 
pressed to accept the job, the light above the button flashes green to indicate the job has been accepted and stops flashing on all other 
boxes. This system provides the information necessary to react quickly to work station requests and drive efficiency improvements 
based on data that was previously unavailable.

A PDF of this Solutions Guide is available at https://goo.gl/4lnsjm
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Model Description
K70DXN2T2GRYQ or 
K70DXN9T2GRYQ 

EZ-LIGHT K70 Wireless Touch 
Select either 900 MHz or 2.4 GHz ISM radio to match the DXM100  

DX80N9Q120BL-RG or 
DX80N2Q120BL-RG

Sure Cross Wireless Q120 Six-Button Box 
Select either 900 MHz or 2.4 GHz ISM radio to match the DXM100  

DXM100-B1C1R1 or 
DXM100-B1C1R3

DXM100 Wireless Controller with Cell 
Select either 900 MHz or 2.4 GHz ISM radio to match the Q120s and 
K70s  
C1 only necessary if cellular communication is desired
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The following guide demonstrates how to bind the wireless six-button boxes and K70 Touch to the DXM and load a preconfigured XML 
file and script for 18 stations. The XML file only requires some minor modifications to be customized for any site.

On each forktruck:
• Box #1: Used for Stations 1-6
• Box #2: Used for Stations 7-12
• Box #3: Used for Stations 13-18.

In the example, three forktrucks are 
being used for 18 stations. 

All the necessary Node IDs are 
shown. Up to three more forktrucks 
could be added using the information 
provided in Step 1.

Step 1: Bind the System and Assign Addresses
Binding the Q120 six-button boxes to the DXM100 establishes a secure radio connection and assigns a specific network address to each 
box in the wireless network. The first 18 Nodes in the system are reserved for binding the Q120 boxes and they must be bound in a 
specific order. Each set of boxes on forktrucks needs to be bound according to the table shown below.

1. Apply power to the DXM.
2. On the DXM: Use the arrow button to select the ISM Radio menu on the DXM’s LCD. Press Enter. 
3. Select Binding and press Enter.
4. Select Bind to > 1 (the first Node) and press Enter.
5. On Q120 Node 1: Triple-click the binding button between 

buttons 1 and 4. The LED flashes four times after it binds to 
the DXM. This Node is now bound as Node ID 1. Label the 
Q120 for future reference.

6. On the DXM: Press Back to return to the main menu.
7. To bind additional Q120s, select Bind to > X (use the table to 

determine the Node ID) and press Enter.
8. On the second Q120: Triple-click the binding button.

If more Q120s are used in the system, continue binding until all Q120s 
are bound to the DXM with each having their own Node ID. 

Bind the K70 Touch lights for each station as Nodes 19 through 36, with Node 19 being station 1 and Node 36 being station 18.
1. Apply power the K70s.
2. Apply power to the DXM.
3. On the DXM: Use the arrow button to select the ISM Radio menu on the DXM’s LCD. Press Enter.
4. Select Binding and press Enter.
5. Select Bind to > 19 (the first Node) and press Enter.
6. On K70 Station 1: Remove the base section by holding the lighting modules and twisting the base clockwise. Triple-click the 

binding button.
The LED flashes four times after it binds to the DXM. This Node is now bound as Node ID 19. Label the K70 for future 
reference.

7. Reconnect the K70’s base to its light module.

1 2 3
1 1 7 13
2 2 8 14
3 3 9 15
4 4 10 16
5 5 11 17
6 6 12 18

Q120
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8. On the DXM: Press Back to return to the main menu.
9. To bind additional K70s, select Bind to > 20 and press Enter.
10. On K70 Station 2: Repeat steps 6 through 8.

When you are finished binding, press Back on the DXM until the DXM returns to the main menu.

Step 2: Run a Site Survey
Verify the wireless connection between your Q120s, K70s, and the DXM by running a site survey on the DXM100.

1. On the DXM: Use the arrow buttons to select the ISM Radio menu. Push Enter.
2. Select the Site Survey submenu and press Enter.
3. Select each Node ID within the system to verify the wireless connection between the Node and the DXM.
4. When you are finished running the site survey, press Back twice to return to the main menu.

Step 3: Configure the System
To customize the system to an actual application, some basic modification to the template files is necessary. There are two files 
uploaded to the DXM: the XML file sets the DXM’s initial configuration and the ScriptBasic file reads the status of call request, controls 
the output to the Q120 requests, acknowledges request, times request and acknowledgement, establishes a reset function for each 
K70s timers and counts, and organizes the information in logical and easy-to-find registers in the DXM.

Loading these files and making adjustments requires Banner’s DXM Configuration Tool software and the “Call For …” files available using 
in the links below.

1. Download the preconfigured files. (https://goo.gl/x2hLto)
2. Extract the ZIP files into a folder on your computer. Note the location where the files were saved.
3. Connect the DXM using the supplied USB cable to a computer containing the DXM Configuration Tool software or download 

the software and install it on a computer.
4. Launch the DXM Configuration Tool software.
5. Load the “Call For…” XML file by going to the File > Load menu and choosing the configuration files.
6. Connect the software to the DXM by going to the Device > Connection Settings menu. Select Serial and then select the COM 

port that the USB cable is plugged into. Click Connect. If you are unsure which COM port and several appear, attempt to 
connect to each one of them until successful.

7. Upload the “Call For…” script file by going to the Settings > Scripting screen. Click Upload Script and select the file.
8. Select the uploaded file in the window to the right of the Upload Script button. Click Add Selected to Startup; the DXM will 

run this script every time it restarts.
9. Save the XML file using the File > Save menu. Save the XML file any time the XML has been changed because the tool does not 

autosave.

Optional Steps: Customize the XML file
1. Within the DXM Tool, go to the Local Registers > Local Registers in Use screen.
2. Rename the stations using the text boxes within the Register Name column. Because there are five registers per station, copy 

and paste names for efficiency.
To display the station status, count, 
or timer on the website, you must 
change the Web column drop-down 
lists to Read and Cloud Reporting 
to ON for each stations’ information 
(status, timer, count, etc.) that you 
would like to appear on the website.

http://info.bannersalesforce.com/intradoc-cgi/nph-idc_cgi.exe?IdcService=GET_FILE&dDocName=b_4440714&RevisionSelectionMethod=Latest&Rendition=web
http://info.bannersalesforce.com/intradoc-cgi/nph-idc_cgi.exe?IdcService=GET_FILE&dDocName=b_4207381&RevisionSelectionMethod=Latest&Rendition=web
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3. To display the statuses for each Station on the website, change the 
cloud permissions.
a) On the Modify Multiple Registers screen, select Change in the drop-
down list next to Cloud Permissions and Cloud Reporting.
b) In the drop-down list to the right, select ON for Cloud Reporting and 
Read for Cloud Permissions.
c) Set the Starting Register to 1 and the Ending Register to the value 
equal to 5 × Number of Stations in the system (for example, set the 
ending register  to 90 for 18 stations).
d) Click Change Registers at the bottom right of the section.

4. Configure to Receive Email or Text Alerts based on an Action Rule.
a) Click on the Action Rules tab and expand any rule using the arrow next to the rule OR create a new action rule using the 
Add Threshold Rule button on the top.
b) Click on the arrow next to Email/SMS on State Transition.
c) Select the recipient of the SMS and/or email upon the action rule becoming true.
In the example shown, both SMS Recipient 1 and 2 and Email Recipient 1 and 2 will receive a message when the action rule 
meets its criteria.
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Step 4: Set up the Ethernet or Cellular Connection
By default, the XML file configures the DXM100 with an Ethernet Push interface with the ability to send emails and push the data 
registers to a webserver. The device can also be configured to use a cellular push if the DXM Controller contains a cellular module and 
data plan. This section is only necessary if the user wants to receive or display information beyond just the DXM Controller's LCD.

1. If the DXM will text, email, or push to the cloud webserver, set up the push interface.
a) On the DXM Configuration Tool, go to the Settings > Cloud Services screen.
b) Select the appropriate Push Interface (Ethernet or Cell) from the drop-down list.
Selecting Cell requires a cellular module be installed in the DXM Controller and a wireless plan be set up for sending data.

2. The Cloud Push Interval determines how often the DXM pushes the current status data to the webserver. By default, this 
interval is set to zero and should not be changed. If data is being pushed to the cloud, set the Cloud Push Interval to 00:15:00 
(15 minutes). 

3. Set up the email and text messages. SMS works only if the DXM has a 
cellular module. Expand the Email Recipients and SMS Recipients to 
enter up to 10 email addresses and 10 phone numbers, along with a 
custom message.
a) Go to the Settings > Mail and Messaging screen.
b) All SMTP fields should remain set to their default values, except the 
Password field. Enter “sxiemail1” into the password field.
c) Click Send SMTP Password.
d) Click Yes when asked to reboot the device.

Step 5: Save and Load the XML File
When changes are made to the XML file, save the changes. To apply the changes, load the XML file to the DXM.

1. Save the file by going to the File > Save menu.
2. Load the file onto the DXM by going to the Device > Send Configuration to Device menu.

Because of the size of the XML file, the file may take up to three minutes to load. Verifying the file is loading by looking at the 
Application Status indicator in the status bar.

If the Application Status indicator is red, close and restart the DXM Configuration Tool, unplug and re-plug in the USB cable and 
reconnect the DXM to the software. If the Application Status indicator is green, the file upload is complete. If the Application Status 
indicator is yellow, the file transfer is in progress.
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Step 6: Push Information to the Cloud
The DXM100 can connect to the web via Ethernet or an internal cell module to push data from the site to display on a website. To 
enable this capability for remote monitoring and alarms settings, modify the XML file.

The website for storing and monitoring the system's data is https://data.sensonix.net/.
1. Connect the DXM to a computer with the DXM Configuration Tool software.
2. Launch the software and connect to the DXM.
3. Load the saved XML file.
4. Go to the Settings > Cloud Services screen.
5. Visit the Sensonix Web Services website (https://data.sensonix.net/) and log into an existing account or register a new account.
6. Click + New Site and name your site.
7. Go to the Settings > Sites webpage.
8. Highlight and copy the Site ID.
9. On the DXM Configuration Tool: Return to the Settings > Cloud Services screen and paste the copied ID into the Site ID field.
10. Save the XML file (File > Save).
11. Upload the file to the DXM (Device > Send Configuration to the Device).
12. On the Sensonix Web Services website, click Send XML to Web and select the XML file that was just saved and uploaded to the 

DXM.
This creates continuity between the site created on the website and the DXM used in the field. The DXM pushes data to the website, 
which can be viewed at any time. Refer to the Sensonix Web Services Instruction Manual to review all the features available for 
monitoring, comparing data, and establishing warnings/alarms on the website.

https://data.sensonix.net/
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Additional Features
Resetting the Timer and Counts
Each station in the system has a reset register available from the DXM’s menu system and via the website. Setting this register to 1 
resets all the counts and timers on that particular station.

Resetting from the DXM
1. On the DXM: Use the arrows to select Registers. The registers are labeled Reset X (where X is the K70 station number you want 

to reset). There is also a Reset All that resets all statistics for all stations.
2. Select the appropriate register to reset.
3. Click the Enter button.
4. Change the value to 1 then click Enter three times. The reset register automatically returns to zero after the stations reset.

Resetting from the Website
1. Go to the Dashboard > Sites screen.
2. Click Update Device for the site where the particular station exists. 

The Update pop-up window appears.
3. From the Type drop-down list, select Register.
4. From the Register Name drop-down list, select the station you want to reset.
5. Enter 1 into the Value field and click Queue.
6. Repeat steps 4 and 5 for each station that needs to be reset or select the Reset All register in step 4.

When the next data push occurs, the chosen units reset. The reset register value automatically returns to zero after the station 
is reset.

Configuring Time Stamped Logging
To setup time-stamped logging, follow these steps.

1. Go to the Local Registers > Modify Multiple Registers screen.
2. Click Reset Form.
3. From the SD Card Logging drop-down list, select Change.
4. Select Log 1 in the drop-down list that appears to the right.
5. Set the Starting Register to 1 and the Ending Register to the value equal to 5 × Number of Stations in the system (for example, 

use ending register 90 for 18 stations). 
6. Click the Change Registers button on the bottom right portion of the section.

Retrieving a Log File
1. Connect the DXM to the computer via USB or Ethernet. Connect the DXM Configuration Tool software to the DXM using the 

Device > Connection Settings menu.
2. Go to the Settings > Logging screen.
3. Click Refresh List.
4. In the Log File Management window, select the file to save.
5. Click Save Selected to save the file to a folder on your computer.



Banner Engineering Corp., 9714 Tenth Ave. No., Minneapolis, MN USA 55441 • Phone: 763.544.3164 • www.bannerengineering.com • Email: sensors@bannerengineering.com

Call for Parts Solutions Guide

P/N b_4440832 Rev. A

© Banner Engineering Corp. All rights reserved

Local Registers
Local Register # Description

Station Information 1 + 5 × (N − 1) Current Request Status

2 + 5 × (N − 1) Total Timer from beginning of Requests

3 + 5 × (N − 1) Total Count of Requests

4 + 5 × (N − 1) Time to Acknowledge Requests

5 + 5 × (N − 1) OFF Time Total

K70 Output 1 100–117 K70 1–18 Output 1

K70 Output 2 118–135 K70 1–18 Output 2

Acknowledge 136–153 Acknowledge Station Status

Acknowledge Time 154–171 Time After Acknowledge set

Box Input Status 200–217 Box 1 thru 18 Input 1

218–235 Box 1 thru 18 Input 2

236–253 Box 1 thru 18 Input 3

254–271 Box 1 thru 18 Input 4

272–289 Box 1 thru 18 Input 5

290–307 Box 1 thru 18 Input 6

Box Connection Status 308–325 Box Connection Status

Box Output Status 326–343 Box 1 thru 18 Output 1

344–361 Box 1 thru 18 Output 2

362–379 Box 1 thru 18 Output 3

380–397 Box 1 thru 18 Output 4

398–415 Box 1 thru 18 Output 5

416–433 Box 1 thru 18 Output 6

Resets 452 Reset All Stations

453–470 Reset Station 1–18

Where N represents the station number.


