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DXM Configuraton Tool v3

1 DXM Configuration Tool

Configure the DXM Controller using the DXM Configuration Tool. The DXM Configuration Tool can be used stand-alone or connected to
the controller using USB or Ethernet. The tool creates an XML file defined for the DXM Controller and can be used at the website level
for configuration.

The DXM Configuration Tool restricts the naming of registers and rules to characters a-z, A-Z, 0-9, # $ _ - () space.
Use the DXM Configuration Tool either while connected to a DXM Controller or as a standalone configuration software.

There are two top-level menus similar to other Windows programs: File and Device. B Connection Settings . |

« Use the File menu to manage the loading and saving of the XML

configuration file created by the DXM Configuration Tool. @Serial @TCorP
= Use the Device menu to handle the connection settings to the DXM Sena =

Controller as well as upload or download the XML configuration files. Also

part of the Device menu is the communications tools used to view data

traffic on the serial bus, useful in ScriptBasic programming. Comm Part: -

Cancel | Connect |
Mot Connected

Connect to the DXM Controller by selecting the Device > Connection Settings menu. Connect via USB or Ethernet. Before attempting an
Ethernet connection, first connect using USB so you can configure the Ethernet parameters before you connect to a live network.

Banner recommends disconnecting the COMM port through the Device menu before turning off power or disconnecting the USB cable.
Use Device > Reboot to restart the DXM Controller if needed; the tool automatically disconnects the COMM port, then reconnect it
again.

For a simple tutorial using the DXM Configuration Tool see the DXM Controller Configuration Quick Start Guide.

Right-click on most fields to access a context-sensitive menu. The most common options in the menus are Cut, Copy, Paste, Delete, and
Insert to make data entry easier.
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2 Software Screens

The following sections explain the function of each screen.

2.1 Action Rules

Action rules allow for simple logic functions and simple manipulation of local register data. The processing of an action rule is
autonomous from other local register functions. Threshold rules provide the mechanism to create event-driven conditions, such as
events to the cloud, local logs, or an email address. There are three groups that make up action rules.

Read rules are executed first, beginning with the first rule defined. The read rules execute in the order they were entered into the DXM
Configuration Tool. After all read rules execute, the write rules are processed, in order. After the write rules are processed, the system
begins again with the read rules.

Processing the read/write rules takes a long time to complete, not because they take a lot of processing power, but because each rule
has a lengthy overall communication time relative to the processor execution cycle time. So, in parallel, action rules are solved. Each
action rule is processed in order, similar to the read/write rules. The groups of action rules are solved in this specific order:

Constants are applied first, cancelling any changes that may have occurred from other sources

Calculate (Math) rules are next, continually processed

Copy rules, processed only when a change of state is detected on the source register

Threshold rules, continually processed

Control Logic, continually processed

Trending, continually processed

Trackers, continually processed

Noghkowpne

2.1.1 Control Logic

Control Logic rules are binary rules, with the results being either 0 or 1. In contrast, the Math Logic rules deal with 32-bit register logic
with results from 0 to 4,294,967,295.

Control Rules create memory elements using the DXM Local Registers as inputs and outputs. A value of zero in a Local Register is
defined as 0 in the Control Rule, a non-zero value in a Local Register is defined as a 1 value. Control Rules are evaluated when an input
value changes state.

The Set/Reset Flip-Flop, or S/R Latch, is the most basic memory device. The S input sets the output to 1, and the R input sets the output
to 0. The invert flag turns the inputs to low active, so a 0 on the S input set the Q output to 1. The truth table below is defined without
the invert flag.

Set/Reset (S/R) Flip-Flop

s R Q onl

1 0 1 0

0 0 No change No change
0 1 0 1

1 1 Invalid 2

The Delay (D) Flip-Flop takes the D input to the outputs at the next rising edge of the clock. All other states of clock have no effect on
the outputs. The Enable input is optional. A Clock input and a D input changing at the same time results in an undetermined state.

Delay (D) Flip-Flop

*Enable D Clock Q *Qn
0 X X No change No change
1 X Oorlor No change No change
1 0 ™ 0 1
1 1 T 1 0

The Toggle (T) Flip-Flop toggles the state of the output if the input is 1. The Enable input is optional. A Clock input and a T input
changing at the same time results in an undetermined state.

1 Optional inputs or outputs. Leave the optional inputs or outputs connected to 0 when not used.
The Set input and Reset input active at the same time is an illegal condition and should not be used.
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Toggle (T) Flip-Flop

*Enable T Clock Q *Qn
0 X X No change No change
1 X Oorlor No change No change
1 0 ™ 0 1
1 1 ™ (toggle) (toggle)

If J and K are different, the output Q takes the value of J. The Enable, Clock, and Qn connections are not required for operation.

J-K Flip-Flop
*Enable J K *Clock Q *Qn
0 X X X No change No change
1 X X Oorlor{ No change No change
1 0 0 ™ No change No change
1 1 0 ™ 1 0
1 0 1 ™ 0 1
1 1 1 ™ No change No change

The Binary Logic rules are based on zero and non-zero values and result ina 0 or 1. If an input is zero it is false (0), and if a value is non-
zero (anything but zero) it is considered true (1). All but one Binary Logic rule requires two inputs; the NOT rule only has one input.

Optionally, the Binary Logic rules can have a Clock input and an Enable input. The Clock input determines the time (0-1 rising edge) the
rule is evaluated. The Enable input enables or disables the logic function. Binary logic rules have the following functions:

e AND—Output is high (1) only if both inputs are non-zero

e OR—Output is high (1) if either input is non-zero

e XOR—Output is high (1) if either, but not both, inputs are non-zero

* NOT—Input is inverted to the output

 NAND—Output is low (0) if both inputs are high (> 0)

 NOR—Output is high (1) if both inp uts are zero (0)

Create a Control Rule

1. From the Action Rules > Control Logic screen, click Add Control Rule.

Name your new rule.

Select the logical operator from the Gate drop-down list.

From the drop-down lists, select the Input 1, Input 2, Enable, and Clock options.
Select the Output options.

a s en

2.1.2 Math and Logic

Use the Math/Logic Rules screen to define simple operations using local registers.

Thresholds | Register Copy JLLEGTRE D) Trending
‘

Opoation  Local Rogister And/Thvough Lot Register  ABGcEng h folowing regiters  Stoes he fesull 1

12 5 Average Temg

‘5' OO0 | | D B | Bed —
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Some operations are valid for ranges of registers. Select And or Thru to select two registers or multiple registers in a range. Average,
Sum, and Logic Operations are valid for ranges of multiple registers. The local registers are unsigned 32-bit integers. All math and logic
functions can operate on all 32-bits. The local register operations are:

Add—Adds two local registers and stores the result in a local register.

Average—Averages the values of multiple registers and stores the result.

Divide—Divides local register 1 by local register 2 and stores the result. Dividing by zero results in a zero.
Logic NOT—Performs a bit-wise one's complement on a local register and stores the result.

Logic OR, AND, NOR, NAND, XOR—Performs bit-wise logic function on multiple registers and stores the result. Bit-wise logic
functions operate on all 32-bits of the Local Registers.

Multiply—Multiplies one local register by another and stores the result.
Sum—Adds multiple contiguous local registers and stores the result in a local register.

Subtract—Subtracts local register 2 from local register 1 and stores the result. For negative numbers, the results are in two's
complement form.

Create a Math Rule

Use math rules to perform mathematical calculations on registers and store the results.

1.
2.
3.
4

5.

From the Action Rules > Math/Logic screen, click Add Math Rule.

Enter a Name for your new math rule.

Select the desired Operation from the drop-down list.

Select the starting Local Register, And or Through, and the second (when using And) or ending (when using Through) Local
Register to perform your mathematical calculations on.

Select the Local Register you'd like to store your results in.

2.1.3 Register Copy

Use the Register Copy screen to copy a local register into another local register or range of registers.

agicle Thresholds JIREWERGIEe G Math 7 Logic | Trending

Add Copy Rule il Delete Last Rule

Regisie apping E To Register  Through Register  Affecting the following registers
e T - || [Analogl 1
|{|| B Analogtn ||| 40 52| ﬁmﬁu:mz

Add New Rule—Creates a new copy rule.
Copy Register—Starting register of the data source range of registers.

To Register—Starting register of the data target range of registers.
Through Register—Ending register of the data target range of registers.

Create a Register Copy Rule

1
2.
3.

From the Action Rules > Register Copy screen, click Add New Rule.

Enter the Copy Register. This is the first register for the source of the data.

Enter the To Register and Through Register. These are the registers for the beginning and end of the target range of registers.

= If you are copying the contents of one register, enter the same register number into the To Register and Through Register
fields.

= If you are copying a range of registers, the range is defined by the To Register and Through Register. The Copy Register is
the starting register of the source range.

www.bannerengineering.com - Tel: 763.544.3164



DXM Configuraton Tool v3

2.1.4 Thresholds

A Threshold Rule triggers event messages sent to the cloud (event-driven push), triggers events to be stored to the local event log. and
creates a standard push message to the cloud with all defined registers being sent.

A Threshold rule creates a simple IF-THEN-ELSE comparison for a register to determine its value and set another register to indicate if
the rule is true or false (you must select a true option to also set a false option). The definition section of the threshold rule sets the
comparison and values. The definitions of the threshold rules can further be defined by the optional parameters, Hysteresis, On Time, E-
mail/SMS and Logging options.

The local register value is the raw register value. The display scaling and offset are not applied for these comparisons.

Local Registers LGB Register Copy | Math / Logic | Control Logic | Trending | Trackers

IMHTHWRWJ lbﬂmmﬁuhl

Register Mapping New threshold rule When register 1 (input A) greater than or equal to 1234 set register 2 (Capped Vaiue) to 1234 else set to register 1 (input A)
Action Rules When local regéster 1% InputA|= > ||Value |~ 121 3
[X] when TRUE, set local register 2 % Capped Value to (Value - 123 3
Scheduler [] When register 1 (input A) less than 1234
Setregister 2 (Capped Value) to |Register - 14 Inputa

Register View
[ save threshold events to cioud

[ Save threshold events to event log
[[] Push when active

Hysteresis value 0%

Record the number of minutes

Minimum on time (Mmm:ss) 0000000 = | | thatthe rule has been true

Sefttings 1o register [

Minimum off time (hhommcss) 00:00:00 %

~ | E-mail’SMS on State Transition

Create threshold rules to compare register values using mathematical functions.

Changed By—Local register value was changed by a defined value or local register value. The minimum On Time can be applied to
define a time period at which the rate of change can be applied. This special treatment of the On Time parameter only applies to the
Changed By comparison.

E-Mail/SMS—When a Threshold rule becomes active or inactive the controller can send and E-Mail or SMS message. Select which
recipient should be notified when this rule is changes state. SMS messages can only be sent when cellular is selected as the network
interface. (Settings > Cloud Services).

Equal To—Local register value is equal to a defined value or local register value.
Greater Than—Local register value is greater than a defined value or local register value.
Greater or Equal To—Local register value is greater than or equal to a defined value or local register value.

Hysteresis—Optional parameter that is enabled only when vales are nonzero. How hysteresis is applied depends on the comparison.
For a test that becomes true 'if greater than,’ the test will not return to false until the local register is less than the test value by a
margin of at least this hysteresis value. If a test becomes true 'if less than," it will not return to false until the local register is greater
than the test value by a margin of at least this hysteresis value. Minimum On Time and Minimum Off Time are time-based parameters
that govern how long a statement must be true or false to activate the output register.

Less Than—Local register value is less than a defined value or local register value.
Less Than or Equal To—Local register value is less than or equal to a defined value or local register value.

Logging Options—Threshold rules create events. These events can cause certain actions to occur, such as:
« Sending threshold events to the cloud. An immediate push with the threshold register states is sent to the webserver when this
rule becomes active.
« Saving the state to an internal event log. Go to Settings > Logging to set up the event log.
« Pushing data to the cloud when the threshold rule becomes active. All local registers with the Cloud Reporting parameter ON
will push to the cloud. (Local Registers > Local Register Configuration)

Not Equal To—The local register value is not equal to a defined value or local register value.
On Time—Stores in a local register how long (in minutes) the Threshold rule has been true.

Create a Threshold Rule

1. From the Action Rules > Thresholds screen, click Add Threshold Rule.
Enter the local register you are comparing.

Select the mathematical function and value.

Select what the system should do if the register value is true or false.
Select any other vales, such as Hysteresis, On Time, or Logging Options.
Select any email or text messages you'd like sent upon a state transition.

2R L S N
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2.1.5 Tracker Rules

Tracker rules monitor a Local Register and count the number of register transitions from 0 to a non-zero value (rising edge). The count is
stored in another Local Register defined as the result register.

The speed at which it can count depends on how much work the DXM Controller is performing. Typical tracker rates should be around 1
to 2 times per second.

Local Registers Thresholds | Register Copy | Math / Logic | Control Logic | Trending | RICH.GE

lAﬂdTracloerRulel ]Dele'ieLas‘lRule|

Register Mapping

Action Rules

Register to Track Result Register

Track Machine [Off-On 1 X vore

Scheduler

Register View

Settings

Create a Tracker Rule

1. From the Action Rules > Trackers screen, click Add Tracker Rule.
2. Name your new tracker rule.

3. Select the Registers to Track from the list.

4. Select the Results Register to store the count in.

2.1.6 Trending and Filters

Use Trending rules to find the average, minimum, and maximum values for a specific register at a user-specified time interval. The Trend
function collects data when the device boots up and accumulates the average, minimum, and maximum values for a register.

Local Registers.

Register Mapping

Action Rules

Scheduler

Fogster 1o Tack  Sampie inferval Filler  Filler Window Vil - w Fesed Trond Data ;ﬂﬂ_'

Register View

Settings

The filter and tracking is applied according to this flowchart.

8 www.bannerengineering.com - Tel: 763.544.3164
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Sample
Interval
Enable
Register

Avg Register

Register InpUt Trending

. . Min Register
to Track Filter Engine

Max Register

Input Filter Input Filter Reset
Window Register

The Trending rule has an optional filter input, and the filter output is the input to the Trending operation. The filter result is used before
applying the Trending rule when you define the Filter Register parameter. The possible filters are:
Cumulative Average—Sums the samples and divides by the number of samples.
Exponential Moving Average—A moving average filter that applies weighting factors that decrease exponentially. The weighting for
each older sample decreases exponentially, never reaching zero.
Lulu Smoother—Takes the minimum and maximum values of mini sequences of sample points. The mini sequence length is defined
by the filter window parameter.
Median Average—Takes a least three sample points, sorts the sample points numerically, and selects the middle value as the result.
A new sample point into the filter removes the oldest sample point.
Recursive Filter—Created from a percentage of the current sample plus a percentage of past samples. The number of samples is
determined by the Filter Window parameter.
Simple Moving Average—Takes the number of samples defined by the Filter Window parameter and averages the samples for the
result. When a new sample is taken, it becomes the latest sample point, and the oldest sample point is taken out of the filter
averaging.
Weighted Moving Average—A moving average filter that applies a weighting factor to the data based on when the data was
captured. More recent data has a higher weighted factor.

The other Trending parameters are:

Average Value Register—The Local Register number to store the average value of the Trending rule. The average is calculated from the
beginning of power-up or from the Reset Trending time. (Hourly, Daily)

Enable Register—Set to 1 to turn on trending; set to O to turn off trending. When disabled, the current data is held until the rule is
enabled again.

Filter—Defines the specific filter algorithm to apply to the front-end of the Trending rule.

Filter Register—The Local Register that stores the output of the first stage filter. This is not required to connect the filter front-end to
the Trending rule processing.

Filter Window—Defines the number of samples for a filter algorithm.

Maximum Value Register—The Local Register number to store the Maximum value of the Trending rule. The Maximum is captured
from the beginning of power-up or from the Reset Trending time. (Hourly, Daily)

Minimum Value Register—The Local Register number to store the Minimum value of the Trending rule. The Minimum is captured from
the beginning of power-up or from the Reset Trending time. (Hourly, Daily)

Register to Track—Local Register to provide the input to the filter and Trending rule.
Reset Trend Data—Use to reset the Trend data accumulation. (Hourly, Daily, or not at all)
Sample Interval—Defines the time interval of the samples to collect from the Local Register.

Create a Basic Trend Rule
See Trending and Filters on page 8 for definitions of all parameters and user-defined fields.
To create a basic Trend rule, follow these steps.

1. From the Action Rules > Trending screen, click Add Trend Rule.
2. In the Name field, name your Trend Rule.

3. Set the Enable Register parameter to 1.
The Enable Register turns on the Trend rule when the register is set 1 and turns off the Trend rule when set to 0.

www.bannerengineering.com - Tel: 763.544.3164 9
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Define the Register to Track.

Define the Sample Interval (hours:minutes:seconds) you'd like to collect the data.
Select Filters and your Filter Window.

Enter the Local Registers to copy the Average, Minimum, and Maximum values into.

No ok

2.2 Local Registers

The main storage elements for the DXM Controller are its local registers. The local registers store up to 4-byte values that result from
register mapping, action rules, or ScriptBasic. Since a Modbus register is only 16-bits, all transactions with Modbus devices use the lower
2-bytes (16-bits) of the local registers.

The local register characteristics are defined on the Local Registers tab of the DXM Configuration Tool.
« Local registers 1-845 are 32-bit unsigned integer based registers.
= Local registers 846-850 are special function registers that can be constants, timers, or reset registers.
« Local registers 851-900 are non-volatile registers with limited write capability for permanent data storage.
« Local registers 1001-1900 are 32-bit IEEE 754 floating point registers.

2.2.1 DXM Display

Use the Local Registers > Local Register Configuration screen to define which registers can be displayed under the Register menu of the
DXM Controller. Use the DXM Display screen to adjust the display order of the Registers with LCD Permissions. If the display order is
not specified, the registers display in numerical order.

Local Register Configuration | Modify Multiple Registers | Local Registers In Use JInx (il EWE Protocol Conversion Overview

Registers with LCD permissions

Register Mapping 1 [Anadgmt
2 [Disteteowts | IEI —
Action Rules 3 Analog In2 |i|
4 Distrete Out? tm
Scheduler 5 [ Humiiy
6 Temp F

Register View

The Local Registers defined to be displayed on the LCD menu are shown in the left column.
1. Select the Local Register by clicking next to the Registers with LCD Permissions number.
2. Click the arrow button to populate the Registers with LCD Permissions in the Display order column.
3. After defining the Local Registers to display, adjust the order using the up and down arrows to the right of the Display order
column.
The display order can also be adjusted by selecting, dragging and dropping register within the Display order column.

If there are more Local Registers defined with LCD permissions than there are in the Display order column the remaining registers will
be displayed in the order of the Local Register number. A Local Register can only be shown once on the LCD.

2.2.2 Local Register Configuration

Graliersss (KL RSN S ge LB Eil R Modify Multiple Registers | Local Registers In Use

5
4

Register Mapping

=
&

c
R

Action Rules

;

;

Scheduler

Register View

Settings

O, -

Click on the arrow of the local register to expand the window to show all characteristics that can be configured with the tool.
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[ELENEN AL ENBL I | Modify Multiple Registers | Local Registers In Use || Protocol Conversion Overview

Local Registers

Register Mapping

Logging and Protocol Conversion

SD Card Logging: None -
Protocol Conversion: None hd

Nane he
Sign Type: unsigned -
Scaling None -
LCD Permissions: None he

Action Rules

Cloud Reporting: Off - Host Timeout Parameters

Cloud Permissions: None he

If the host fails to communicate with this register for

Scheduler

0 + seconds, set the register to: 0%

The configurable characteristics are:

Cloud—Enables the cyclical reporting of this register value to the web site. The rate of the cyclical push of data is defined under the
Settings > Cloud Services tab. The Cloud Permissions flag defines how the local register is displayed and controlled at the web server.

Constant—Forces the local register to be set to a user-specified value. This can be useful to compare values when using action rules.

Display Information—Units, Sign Type, Scaling and LCD Permissions define the display characteristics for the web site and DXM LCD
registers menu.

Host Timeout Parameters—Provides a safety net mechanism for failed communications situations between a host system and the DXM
Controller. If a host system fails to interact with this register for a user defined time, the register will be set to a user defined value.

Logging and Protocol Conversion—Defines the onboard micro SD card storage of this local register based on a cyclical rate or an event
change. Up to three different log files can be stored on the micro SD card, each with different logging definitions. The micro SD card logs
are set up under the Settings > Logging tab. The Protocol Conversion section defines this local register to be an input or output when
used with the different protocols enabled on this device. Ethernet/IP™ uses this register definition.

Reset—Local Registers 846-850 are reset registers. These registers reset a processor if the register is not written to within a specified
time. The Reset register is typically used with ScriptBasic to detect if the program is in a bad state. Within the time is specified, the DXM
Controller must be programmed to write to this register before this time limit is reached or the processor is reset.

Timer—A Local Register defined as a Timer increments every 100 ms, or 1 second. Write to the Local Register to start the timer at a
specific value.

Modify Local Registers Individually

This example configuration sets the device to push registers values to the web server.

or Modify Multiple Registers | Local Registers In Use | Protocol Conversion Overview

Local Registers

Register Mapping Constant Value and Counter Logging and Protocol Conversion
17| | [None =) SD Card Logging: None
. Sign Type: unsigned - Protocol Conversion: None
Action Rules
Scaling: divide v

Scalevaluer 100.00 % Scale offset 00000 %
Scheduler LCD Permissions: |Read I=)

Cloud Reporting: on - Host Timeout Parameters

Cloud Permissions: Read - If the host fails to communicate with this register for
0 * seconds, set the register to: o

Register View

Settings

1. Go to the Local Registers > Local Register Configuration screen.

The local registers are a pool of integer and floating point registers that can be used by the controller to save data that was
created, store data from external devices, or store basic constants. The local registers are where the user defines the data sent
to the web server.
This screen shows how each local register is defined.

2. Click on the down arrow next to the first line for Local Register 1.
The parameters for Local Register 1 display.

3. To push the register values to the web server, set Cloud Reporting to ON.

4. Set the Cloud Permissions to read.
If the Cloud Permissions are set to Read, the web server only views data from the device and cannot write data to the device. If
the permissions are set to Write, the web server only writes to the device and cannot read the data. If the permissions are set
to Read/Write, the web server can read the data from the device and write to the device from the web.

This tells the website to display the register and sets this register to read only at the website. The register's contents displays
under the Registers menu.

www.bannerengineering.com - Tel: 763.544.3164 11
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2.2.3 Local Registers in Use

Use the Local Registers in Use tab to view a list of all the local registers used by your device.

Local Register Configuration | Modify Multiple Registers JITETREVEALELY ) Protocol Conversion Overview

Local Registers

Register Name
Register Mapping

Action Rules

Scheduler

Register View

Settings

Modify Registers Using the Local Registers in Use Screen

Use this screen to modify the parameters of any local registers being used.

) Ew— _ . —— - i - )
Local Registers Local Register Configuration | Modify Multiple Registers JITETREVEALELY ) Protocol Conversion Overview

Constant Cloud
of Tmer ]

M omenn BN BlRe - JSCENene ) - Jiflon - HilRead) - JilRea) - Jf{none - Jifnore -
CEND =

ame . . Wl . Protocol -
L] Regster Name Regsier Group Units Sigroed Wb LCO  ooversion 109 Fles

Register Mapping

Action Rules

Scheduler

Register View

Settings

1. Go to the Local Registers > Local Registers in Use screen.
A list of the local registers being used displays.
2. Using the drop-down lists, change the desired parameters.
3. To push register values to the web server, set Cloud Reporting to on and Web to read.

If Web is set to Read, the web server only views data from the device and cannot write data to the device. If the permissions
are set to Write, the web server only writes to the device and cannot read the data. If the permissions are set to Read/Write,
the web server can read the data from the device and write to the device from the web.

This tells the website to set this register to read only at the website. The register's contents displays under the Registers menu.

2.2.4 Modify Multiple Registers

To change multiple registers at once, use the Modify Multiple Registers tab.

12 www.bannerengineering.com - Tel: 763.544.3164
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Local Registers Local Register Configuration ?Modify Multiple Regislersf Local Registers In Use

Modify Registers

. . Starting Register: 1% Ending Register: 1%
Register Mapping o = i =
Modify Properties
Action Rules Name: None i
Constant or counter.  (None -
Scheduler Lt (None ] =)
Sign type: None -
Register View Scaling: None -
LCD Permissions: None -
- Cloud Reporting: None -
Settings [FELE
Cloud Permissions: None -
SD Card Logging: None -
Protocol 102 None -
Host timeout: None -
Reset Form Change Registers

Change Registers—Click to save your changes and apply them to the selected register(s).

Ending register—Ending register in the range of registers to change.

Reset Form—Click to reset any changed data.

Starting register—First register in the range of registers to change.

Modify Properties—List of register properties that can be user-defined. The register properties include:

Name

Register group
Constant or timer
Units

Sign type

Scaling

LCD permissions
Cloud reporting
Cloud permissions
SD card logging
Protocol 10

Host timeout

Modify Multiple Registers

Modify a range of registers from the Local Registers > Modify Multiple Registers screen.
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Local Registers Local Register Configuration JLEGGTTRE T ERSEREREH ) Local Registers In Use | LCD Display | Protocol Conversion Overview

Register Mapping 12 Ending register 1%

Action Rules None " |~

Scheduler None -

Reqister View None |- |

Settings \None | =)

Enter the Starting register and Ending register.

Select the value to change using the drop-down list next to each value.

Enter the new value in the field provided.

To push register values to the web server, set Cloud Reporting to on and Cloud Permissions to read.

If the Cloud Permissions are set to Read, the web server only views data from the device and cannot write data to the device. If
the permissions are set to Write, the web server only writes to the device and cannot read the data. If the permissions are set
to Read/Write, the web server can read the data from the device and write to the device from the web.

This tells the website to set this register to read only at the website. The register's contents displays under the Registers menu.
5. Click Change Registers.

PowbdpE

2.2.5 Protocol Conversion Overview
This screen displays a list of the EitherNet/IP (EIP) Inputs and Outputs associated with DXM Controller registers.

Local Registers

Register Mapping (Exportio G5V

| Protocol Conversion Overview |
: i

Local Register Configuration | Modify Multiple Registers || Local Registers In Use

Inputs used/Total inputs  0/228

Register ID Register Name:

‘Outputs used/Total outputs  0/228

Register ID Register Name

Action Rules

Scheduler

Register View

Settings

Define the Local Registers to be EtherNet/IP registers on the Local Registers > Local Register Configuration screen.

2.3 Register Mapping

The Register Mapping function is has two main components, a read rule and a write rule. As the name implies, the rules allow the user
to program the ability to read or write information from internal or external Modbus slaves to/from the local registers. On the DXM
Controller, use the read/write rules to access the Modbus registers of the LCD display, /0 base board, and the internal ISM radio.

DXM Configuration Tool allows the user to create Write/Read rules that in turn create Modbus messages to external devices. How the
user enters rules affects how a Modbus message is formed. If the user creates three individual read or write rules, those rules create
three individual Modbus messages that will be sent out the RS-485 master port. If the user creates one read or write rule that spans
multiple registers, the result is one Modbus message.

14 www.bannerengineering.com - Tel: 763.544.3164



DXM Configuraton Tool v3

Click on the arrow of the read or write rules to show all the parameters for that rule.

2.3.1 Read Rules

Each read rule defines a Modbus slave ID and register range to read and then store in the local registers. The local register names shown
are the registers that are being used by the read rule.

Local Registers

Register Mapping || (4 From stave 10 ) :m PR rooistors starting at 1 e L —— 1 f

Action Rules Remote type Hoiding register | v 'GPS Reg 1
GFS Reg 2
Froquency 00:00:05.000 5 hhumamss GPS Reg 3
GPS Reg £
Scheduler Scaling Scale value 0% Scale offset [ GPS Rig &
GPSReg 6
Ermor condition Apply valpe 12385 & after 3 3 read failures
Register View Floating point [ Swap words
On register o

Settings

The user defines parameters that can be applied to each read rule.
Error Conditions—Applies a default value to the local register after a user-defined number of Modbus register read fails.

Floating Point - Swap Words—A floating point value is a 32-bit value requiring two consecutive Modbus register reads or writes. The
DXM Controller expects the most significant part of the floating point value to be first (lowest address) followed by the least significant
part. If a Modbus slave device sends the least significant part first, select Swap Words to align the words correctly.

Frequency—Defines the cyclical rate at which the register is read. The maximum cyclic poll rate is controlled by the maximum polling
rate set in the Settings > General screen, the Modbus Master Communications section. Changing that value causes the tool to adjust all
polling rates. For example, setting the maximum rate to 1 second causes the tool to adjust all rules with a frequency of less than 1
second up to 1 second.

Offset and Scaling—Adjusts the read value by multiplying the scale value and then adding the offset value. The result is held in the local
register.

Remote Type—Select the register type from the drop-down list.

Create a Read Rule

Use the Register Mapping > Read Rules screen to create a new read rule. See Read Rules on page 15 for a complete list of user-defined
parameters.

1. Click Add Read Rule.
A new read rule is created.
2. Click the arrow next to the first rule to view the parameters.
The list of parameters opens.
Type in the rule's name in the 'none’ field.
Select slave ID of the source device.
Select the number of registers to read from the source device.
Select the starting register of the source device.
Select the starting register of the local/target device.
Set the desired parameters.

® NG RA W

2.3.2 Write Rules

The write rules write local register data to the defined Modbus slave ID and registers. The local register names shown are the registers
used by the write rule.
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Local Registers
Acd \Wiite Rule | | Delete Last Rule
Reqister Mapping

Action Rules Remote type Holding register | = Local Registers Names
Frequency ‘On Change of local register data > Rd Data 1

Scheduler 'Write when register changes by morethan 0 % Rd D 3
Wit 98 LEAST every 00000:00.000 = Rhomencss. o

Write 3t MOST every  D0.00:00.000 + hhmenss.m

Register View
Scating Scale value 0.000000 = Scale offsat [
Floating point [ Swap words
Settings Use single write command [

The user defines parameters that can be applied to each write rule.

Floating Point - Swap Words—A floating point value is a 32-bit value requiring two consecutive Modbus register reads or writes. The
DXM Controller expects the most significant part of the floating point value to be first (lowest address) followed by the least significant
part. If a Modbus slave device sends the least significant part first, select Swap Words to align the words correctly.
Frequency—Defines how often to write the local register to the Modbus slave device in one of two ways:

Cyclical—Causes a Modbus write based on a timing interval, as fast as possible or a specified time interval.

On Change of Local Register Data—Allows the user to specify a certain criteria when to write to a Modbus slave device. For
example, if the local register changes by a user-specified amount, the write occurs. If the user wants to write the local register to the
Modbus slave at a minimum interval, use the write AT LEAST time setting. Use the write AT MOST time interval to minimize the
write cycles for local registers that change frequently.

The maximum cyclic poll rate is controlled by the maximum polling rate set in the Settings > General screen, the Modbus Master
Communications section. Changing that value causes the tool to adjust all polling rates. For example, setting the maximum rate to 1
second causes the tool to adjust all rules with a frequency of less than 1 second up to 1 second.

Offset and Scaling—Adjusts the local register write value by multiplying the scale value, adding the offset value, then writing to the
Modbus slave device.

Create a Write Rule

Use the Register Mapping > Write Rules screen to create a new write rule. See Write Rules on page 15 for a complete list of user-
defined parameters.

1. Click Add Write Rule.
A new write rule is created.

2. Click the arrow next to the first rule to view the parameters.

The user-defined parameters are displayed.

Type in the rule's name in the None field.

Select the number of registers to write to the target device.

Select the starting register of the local/source device.

Select the slave ID of the target device.

Select the starting register of the target device.

The ending register automatically fills in based on the starting register and the number of registered selected in step 4.
8. Set the desired parameters.

No ok

2.3.3 Processing the Rules
Rules and functions are evaluated by the DXM Controller in a specific order.
1. The read rules are executed first, beginning with the first rule defined and continuing in the order the rules were entered into
the DXM Configuration Tool.
2. After the read rules are executed, the write rules are processed, in the same order.
3. After the write rules are processed, the DXM Configuration Tool starts over with processing the read rules.

The read/write rules take time to complete, not because they require processing power, but because each rule has a lengthy overall
communication time relative to the processor execution cycle time. So, in parallel, the action rules are also solved.

Each action rule is processed in order, similar to the read/write rules. The groups of action rules are solved in this specific order:

Constants are applied first, cancelling any changes that may have occurred from other sources.
Calculate (Math) rules are next, continually processed.

Copy rules, processed only when a change of state is detected on the source register.
Threshold rules, continually processed.

Trending, continually processed.

grLNE
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2.3.4J1939

J1939 is a wired communications protocol standard maintained by the Society of Automotive Engineers (SAE). Commonly used in off-
road and heavy equipment, J1939 is a higher level protocol that is built upon the Controller Area Network (CAN) physical layer
developed and originally published by Robert Bosch GmbH in 1991.

All J1939 messages are sent using the 29 bit message identifier, also known as the extended frame format, described in CAN 2.0B.

Typical J1939 data frames consist of the 29 bit identifier, 8 byte payload, a 15 bit CRC, and 20 additional bits used as flags, delimiters, or
simply reserved for future use. Therefore a typical CAN packet is approximately 29 + 8 x 8 + 15 + 20 = 128 bits long. At the standard rate
of 250 kbits/sec, a J1939 packet is a little over 500 ps long. Actual duration may vary because the protocol defines that "bit stuffing"
shall occur any time there are 5 bits in a row of identical polarity.

There is no centralized network coordination function in a J1939 network. Every node (known as an Electronic Control Unit, or EC) in a
J1939 network "claims" a unique address for itself during network commissioning (after power-up). All ECs on the bus can be producers,
consumers, or both producers and consumers of data. When an EC has data that it wants to write to the bus, it begins transmitting
while simultaneously monitoring the channel for collisions. Collisions can be detected immediately because each bit is sent using a
dominant/recessive scheme and any EC that sees a dominant bit on the channel when it transmitted recessive bit will know to
immediately cease the transmission. This is known as non-destructive bus arbitration.

Note that a minimum of two nodes must be used to initialize communication on a CAN bus. Since a transmitted message must be
acknowledged in the ACK bit by a receiver, the transmitting controller sends out an error flag if the message is not properly ACKed.

Messages in J1939 are organized by a field in the 29-bit header known as the Parameter Group Number or PGN. The PGN may be
thought of as an index into a large data table. The J1939 standard defines what the data means in every such table entry, but also leaves
many PGNs to be defined in a proprietary manner.

For example, the PGN 65262 is defined to contain Engine Temperature. Within the 8 bytes sent with this PGN, the J1939 specification
also defines that byte 1 is for Engine Coolant Temperature, byte 2 contains Engine Fuel Temperature 1, bytes 3-4 encode Engine Oil
Temperature 1, bytes 5-6 encode Engine Turbocharger Oil Temperature, byte 7 represents Engine Intercooler Temperature, and byte 8
is for Engine Intercooler Thermostat Opening.

Theory of Operation

The Banner DXM Controller functions as a protocol converter between its internal local register space and J1939 PGNs.

Users must configure the DXM Controller to select the J1939 PGNs to be monitored, which is known as creating a J1939 Read Rule.
Similarly, the DXM Controller can be configured to transmit messages if desired, which is known as creating a J1939 Write Rule. Read
Rule and Write Rules map out the link between local registers and PGNSs.

Data contained in DXM Controller local registers may be accessed using the scripting engine in the DXM Controller.

At startup, the DXM Controller attempts to claim a unique J1939 address on the CAN bus it is connected to. It does so by sending its
desired address to the PGN OXEEOO and waiting for a reply. The DXM broadcasts the contents of its NAME field, which is specified in the
DXM Configuration Tool using the J1939 Name fields. All sub-fields are currently user selectable except the Manufacturer ID.

The DXM allows two separate methods for specifying the address to claim on a J1939 network. Either one may be used; the choice of
the method can be determined by whichever one is more convenient. In the first method, a list of acceptable addresses is specified. The
DXM attempts to claim the first (leftmost) address, and if denied, will proceed to the next and the next. In the second method, a range
of acceptable addresses is specified and the DXM attempts to claim the lowest, then increment that choice by 1 until it is able to claim
one or reaches the end of the list.

No further J1939 functions (transmitting or receiving) begin until the DXM claims its address. In the DXM Configuration Tool, go to the
Register Mapping > J1939 screen and click Check device for J1939 address to view the current DXM device address. If it returns -1, it
was unsuccessful in claiming an address.

After the DXM has claimed an address, it passively listens to all 11939 traffic. Any messages that contain PGNs for which there is a
matching read rule are decoded and the data is copied into the desired local registers. Any PGNs in the J1939 Write Rules area are
transmitted onto the bus at the interval chosen. Each time a J1939 message is about to be transmitted, the DXM populates the J1939
data fields with the contents of the specified local registers, then writes the message onto the bus.

The acceptance criteria for J1939 Read Rules are:
1. The CAN protocol version must pass. This should always be the case in a J1939 network, but may have to be revisited if this
device is used for other CAN bus applications.
2. The 16 bits that make up the arriving PGN are examined. Specifically the PGN is considered to be the concatenation of the 8 bit
PDU Format and the 8 bit PDU specific fields.

a. Ifthe PGN = 0xF000, then the message destination is global and the PGN is left unaltered as it is handed to the next
layer of the internal stack. The implication of this is that read rules for PGNs in this range should have the PGN in the
rule set to exactly what the device documentation says.

b. If the PGN < 0xFOO0O, then it is a peer-to-peer message and the PGN is considered to be the 8-bit PDU format bits
followed by 8 bits of 0. Put another way, PGN = (PGN & 0xFF00), where & represents a bitwise logical AND operation.

a. Read rules for PGNs in this range should have the PGN in the rule set to mask off the lower 8 bits to zero.

b. Inthis case, the lower 8 bits (PDU specific bits) are the destination address. Destination address = PGN &
OXOOFF.
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c. Ifthe address claimed by the DXM does not match the message's intended destination address, the message is
discarded. To prevent messages from being discarded this way, select Accept peer to peer messages sent to
any address in the DXM Configuration Tool.

Start Up Guide for the DXM Controller

Verify your DXM Controller is powered up and connected to a computer that has the DXM Configuration Tool installed.

Local Registers Read Rules | Write Rules | Rikc:]
Register Mapping

J1939 Name
| Artitrary addross capable Indusiry group Vehicke systom instance Vehicke systom Function Function instance ECU instance Idonlity number
4 02 02 0% [ 0z 0z o

Action Rules

D1 D2 D3 D4 D5 D6 DT D8

Scheduler

(& Find an address in the range: Start address 0 2 Endaddress 0 2
Register View BIF 25 3 % [T Accept peer 1o Poer missages sent 10 any addness

| Read device J1G30 addiess | Current J1939 address -1

11539 Read
| Add 41930 Read | | Dedete Last 1930 Read | |Add 41939 Write | | Delete Last J1930 Write

1. Onthe DXM Controller: Make the wired connection to the bus. Using the labels on the housing decal, CH (pin 16) is for CANH
and CL (pin 15) is for CANL.

2. Onyour computer: Launch the DXM Configuration Tool and navigate to the Register Mapping > J1939 screen.

3. Configure the J1939 Name for the DXM.
All sub-fields of the NAME area are user-configurable except the Manufacturer Code, which is permanently set to 758 (decimal)
as granted to Banner Engineering by SAE.

4. Specify the preferred addresses for the DXM to claim using one of two methods:

« Create an explicit list of addresses in the ID1 through ID8 fields. The DXM attempts to claim the address under ID1 first. If
that address is already taken, it attempts to claim the address under ID2 and continues until it claims an address.

e List the Start address and the End address. The DXM attempts to claim the Start address first and increment sequentially
until it successfully claims or reaches the End address.

5. BIP may be left at 25%. This field is the "babbling idiot protection" and establishes is the maximum fraction of the J1939
channel bandwidth that the internal stack allows the DXM to consume with data transmissions. It is a safeguard to protect the
user from specifying too many or too frequent J1939 transmissions that could cause bus collisions and performance issues.

6. Select Accept Peer to Peer messages sent to any Address to allow the DXM to listen in on peer-to-peer messages that aren't
directed to its own bus address.

Even though most messages on the J1939 bus are sent to a broadcast address, some peer-to-peer messaging is possible.

Settings

Create a J1939 Read Rule

Create aJ1939 read rule to configure the J1939 to monitor for desired Parameter Group Numbers (PGNs) and capture their data.
These instruction assume the DXM Controller is powered up and connected to a computer running the DXM Configuration Tool.

lMdJIQBB‘Re&d: | Delete Last J1939 Read |

Local register byte width

1. From the Register Mapping > J1939 screen, click Add J1939 Read.
2. Enter a name for the rule.

This name does not affect the actual behavior of the system.
3. Enter a Source Address.

= If the bus address of the EC sending the PGN is known, enter that address as the Source Address.
« To accept messages from any source, enter the wildcard value of 255 as the Source Address.

Every J1939 message includes a Source Address, which is the bus address of the device that sent the message. The DXM
Controller filters incoming messages based on this address.
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Enter a Local Register.

The Local Register is the base address in local register memory space that the data should be sent to. When creating multiple
read rules, choose to base addresses spaced so that the same local register does not get written to by multiple read rules.
Enter a PGN.

This is the parameter group number (PGN) of the J1939 message that this rule captures.

« If PGN 2 0xF000, the PGN is a broadcast rule. The message arrives and passes through the stack as long as the PGN matches
the read rule.

« If PGN < 0xF0O00, it is a peer-to-peer message. To be received, the lower 8 bits of the PGN must match the bus address
claimed by the DXM. (This check can be overridden by selecting Accept peer to peer messages sent to any address.)
Because the lower 8 bits of the PGN (also know as the PDU Specific) are used as an address, the PGN in the read rule should
have its lower 8 bits zeroed out to make the matching work.

Enter the Local register byte width.

Local registers are 32 bits, so it is possible to pack 1, 2, or 4 bytes of J1939 data into each local register. For J1939 messages

with 8 bytes of data (the majority), packing means the data consumes 8, 4, or 2 local registers respectively depending on the

choice.

Create a J1939 Write Rule

Create a J1939 write rule to transmit local register data in a J1939 message at a periodic interval.

These instruction assume the DXM Controller is powered up and connected to a computer running the DXM Configuration Tool.

(Ao 1538 i) oot st 1539 e

Mame Address Local register PGMN Local register bybe width ~ Time between sends
Mone o= 12 [ Twig, 2 = e s

From the Register Mapping > J1939 screen, click Add J1939 Write.

Enter a name for the rule.

This name does not affect the actual behavior of the system.

Enter a destination Address for the message.

The broadcast address is 255.

Enter the Local register.

The Local register is the data source's base address in local register memory space.

Enter the PGN.

Only PGNs in the range OxFFOO to OxFFFF are able to be specified by the manufacturer. Use caution when assigning data to
PGNs outside of this range, because the data must adhere to the formatting specified by the Society of Automotive Engineers or
risk being misinterpreted by other ECs on the bus.

Enter the Local register byte width.

Local registers are 32 bits wide, so it is possible to retrieve 1, 2, or 4 bytes of J1939 data from each local register. Because most
J1939 messages have 8 bytes of data, the data is sourced from 8, 4, or 2 local registers, respectively, depending on the choice.

Example: Receive a PGN Using Broadcast Communication

A manufacturer's datasheet for an EC states it transmits its information on PGN 65281d, or OxFFO1.

Because this PGN is in the range 0xFFO0-OxFFFF, the data is manufacturer-specific and not constrained by a definition controlled by the

SAE.

a s wDN e

On the Register Mapping > J1939 screen, click Add J1939 Read to create a new read rule.

Enter a Name, for example, Proprietary_msgl.

Enter the Source address (the sender's bus address) or enter 255 to accept data from any address on the bus.
Enter the Local register (the base address for the data).

Enter a PGN of 65281.

Enter the Local register byte width (1, 2, or 4), which stores the bytes per local 32-hit register.

The following example J1939 message shows the relation between byte order on the bus and in the local register space:
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Bytel Byte2 Byte3 Byte4 Byte5 Byte6 Byte7 Byte8
J1939 Data 0x01 0x23 0x45 0x67 0x89 OxAB 0xCD OXEF
Reg. Address Base Base +1 Base +2 Base +3 Base +4 Base +5 Base +6 Base +7
1 byte/reg OXEF 0xCD 0xAB 0x89 0x67 0x45 0x23 0x01
2 bytes/reg OXEFCD 0xAB89 0x6745 0x2301 (n/a) (n/a) (n/a) (n/a)
4 bytes/reg OXEFCDAB89 0x67452301 (n/a) (n/a) (n/a) (n/a) (n/a) (n/a)

Example: Receive a PGN Sent Using Peer-to-Peer Communication
A manufacturer's datasheet for a sensor says it transmits its information on PGN 52212d, or OxCBF4.

Because this PGN is in the range 0x0000—-0xEFQ0, this is meant to be a peer-to-peer message. The lower 8 bits of the PGN contain the
destination address.

1. On the Register Mapping > J1939 screen, click Add J1939 Read to create a new read rule.

Enter a Name, for example, p2p_msg2.

Enter the Source address (the sender's bus address) or enter 255 to accept data from any address on the bus.

Enter the Local register (the base address for the data).

Enter a PGN of 51968 or 0xCBOO. Note that the lower 8 bits have been masked.

Enter the Local register byte width (1, 2, or 4) bytes per local register.

Enter the Address claim. As a peer-to-peer message, this PGN is intended for the device at address 0xF4 only. There are two
ways to allow the DXM to read this message:

 Have the DXM claim address 0xF4 =244d on the bus; or

« Select Accept peer to peer messages sent to any address

No ok wd

Example: Monitor Diagnostic Troubleshooting Codes

The J1939 standard specifies a method of transmitting diagnostic trouble codes. Active trouble codes are sent using PGN 65226 or
OXFECA (consult the J1939 documentation for other related PGNSs, such as Previously Active Trouble Codes).
1. On the Register Mapping > J1939 screen, click Add J1939 Read to create a new read rule.
Enter a Name, for example, active_DTCs.
Enter the Source address or 255 to accept data from any address on the bus.
Enter the Local register (the base address for the data).
Enter a PGN of 65226 or OXFECA.
Enter the Local register byte width (1, 2, or 4) bytes per local register.
Each diagnostic trouble code consumes 8 bytes, but there may be more than one active code from a given EC. Such longer

messages are sent using the Transport Protocol feature of J1939, which the DXM supports. It is important that the user reserve
enough local register space for the messages in case there are more than the standard 8 bytes.

oA~ W

Example: Transmit a PGN Using Broadcast Communication
To transmit manufacturer-specific data on PGN 65296 or OxFF10, follow these steps.

1. On the Register Mapping > J1939 screen, click Add J1939 Write to create a new write rule.
Enter a Name, for example, tx_msg2.

Enter the Address (the destination address for the message, for example 49d=0x31).

Enter the Local Register (the base address to retrieve the data from).

Enter a PGN of 61184.

Enter the Local register byte width (1, 2, or 4) per local register.

7. Enter a Time between sends of 1500 ms.

o s~ wDd

If this message is observed as a standard CAN bus message, the 29-bit arbitration ID appears as follows: O0x1CEF3116.
e The leading 1C is the priority, which has been set to the lowest, or 8.

EF is the higher 8 bhits of the PGN.

31is the destination address.

16 is the address that this DXM has claimed on the bus.

Example: Transmit a PGN Using Peer-to-Peer Communication

To transmit manufacturer-specific data on PGN 61184 or OXEF0O, follow these steps.
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On the Register Mapping > J1939 screen, click Add J1939 Write to create a new write rule.
Enter a Name, for example, tx_msg2.

Enter the Address.

Enter the Local register (the base address from which to retrieve the data).

Enter a PGN of 65296.

Enter the Local register byte width (1, 2, or 4) per local register.

Enter a Time between sends of 1500 ms.

No agkrwbdE

Send Diagnostic Commands

The DXM firmware supports some diagnostic commands that can be entered through the DXM Configuration Tool. To send these
commands, follow these steps.

1. Go to the Device > View Serial Activity menu.
A Traffic on port COMxx window opens.

2. Inthe single-line text box at the bottom of the window, type a command. Click SEND.
The resulting serial traffic, including response, will be shown. The successful execution of CMDOOxx always results in a response
of RSPOO0xx, followed immediately by one or more parameters (xx indicates the Command Number).

Command (case sensitive, Command Name and Sample Response Fields in Response (after RSPOOxx, where xx = confirmation of

no spaces) Meaning command number

CMDO0080 Address claimed RSP008022 Decimal value of Address claimed by the DXM. For this example, 22.
CMD0081 NAME field RSP00815A5ADAS5EFFFFBADA ASCII string of the DXM's NAME field in hex. The NAME is eight bytes

long, so the field will contain 16 hexadecimal digits.

CMDO0082 Traffic and filtering RSP00820,2,3,4 Totalizing counter. Number of Transmits (0), number of Read Rules
satisfied (2), number of messages passed through stack (3), and number
of messages passed through CAN peripheral of micro (4)

CMD0083 Statistics RSP00830,1,2,3 Statistics on name and address claiming: Name, Address, Address fails,
overrides

CMDO0084 Clear traffic totalizer RSP00840 Clears the totalizer values (traffic counting) that are accessed by
CMD0082

2.4 Register View

Use the Register View screen to read or write local registers within the DXM Controller or Modbus Slave devices connected to the DXM
Controller.

The data format can be decimal or hexadecimal selected by the radio button at the upper left of the page. The selection of using local
registers (DXM Controller) or a Modbus Slave ID is found at the upper right of the page. Connect the DXM Controller using USB or
Ethernet.

Register View

ReadiWiitn Scurce and Format

Data Format |Docimal| = | Source Regater. [Localregaters | = | SavelD 159 © Timecut 5% e

[] Snow tocal register nams (] Apply sig and regeter $¢aing 10 values

sexang ropsir [ W " P S | | sty Repaer
GPSReg 1 o 5 15 RaDatat|o
Scheduler oPS A2 | 15 Rapaaz|n |
Numter of regelers
GFSRM3 |0 = [ Ra0#a3 |0 |
Register View GPSReg 4 |0 15 noon | 0 |
6P3 A5 [0 Wit Regtoiens | 15 e | |
65 A6 o 2 ot | |
Seltings

Data Format—Use the radio button in the upper left to select between the decimal or hexadecimal data format.

Read Registers—To read the contents of a specific register or range of registers, select the starting register and the number of registers
to read from. Select how often to read the registers by selecting Enable Polling and entering the time. Click Read Registers to view the
register values as they display just below the Read Registers section.

Source Register—Use the radio button in the upper right to select between using the local registers or the Modbus Registers of a
specific Modbus Slave.

Write Registers—To write values to a specific register or range of registers, select the starting register and the number of registers to
write to. Enter the value to write to these registers and click Write Registers to send these defined values to the selected registers.
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2.5 Scheduler

Use the Scheduler screens to create a calendar schedule for local register changes, including defining the days of the week, start time,
stop time, and register values. Schedules are stored in the XML configuration file, which is loaded to the DXM Controller. Reboot the
DXM Controller to activate a new schedule.

If power is cycled to the DXM Controller in the middle of a schedule, the DXM Controller looks at all events scheduled that day and
processes the last event before the current time.

Right-click on most fields to access a context-sensitive menu. The most common options in the menus are Cut, Copy, Paste, Delete, and
Insert to make data entry easier.

2.5.1 Create a Weekly Event

To define weekly events, use the Scheduler > Weekly Events screen.

Weekly Events | EeLERIN RSV Y BalTGE S

Local Registers

‘ Add Weekly Event‘ ‘ Delete Last E\renl‘

Register Mapping ~) Weekly event 1 Register Nune acive days: [JAQMGEPEN  start 1 at 220000  End: 0 at NONE
Schedule Definition Holidays
. Active Holidays Available Holidays
Action Rules Start Value: 1 % Startat (SpecficTime|~| 2200 % 24 hour format — aa T ]
[ End Vaiue 0 2 Endat (SpeciicTime]~) 00:01 % 24 hour format Remove

Scheduler

Register View Schedule Definition Holidays

Active Holidays Available Holidays
Start Value: 0 ¢ Startat (SpecificTime | ~| 02:00 3 24 hour format Add
Settings [TEndvalue:| 0 % Endat (SpecficTime] ~)  00:01 & 24 hourformat Remove

1. Click Add New Rule.
A new schedule rule is created.
2. Click on the arrow to the left of the new rule to expand the parameters into view.
The user-defined parameters are displayed.
Name your new rule.
Enter the local register.
Select the days of the week this rule applies to.
Enter the starting value for the local register.
Use the drop-down list to select the type of Start at time: a specific time or a relative time.
Enter the starting time.
9. Enter the end time and end value for the local register.

© N Ok ®

Register updates can be changed up to two times per day for each rule. Each rule can be set for any number of days in the week by
clicking the buttons M, T, W, Th, F, S, or Su.

If two register changes are defined for a day, define the start time to be before the end time. Select End Value to enable the second
event in a 24 hour period. To span across two days (crossing the midnight boundary), set the start value in the first day, without
selecting End Value. Use the next day to create the final register state.

Start and end times can be specified relative to sunrise and sunset, or set to a specific time within a 24 hour period. When using sunrise
or sunset times, set the GPS coordinates on the device so it can calculate sunrise and sunset.

2.5.2 Create a One-Time Event

Define one-time events to update registers at any time within a calendar year. Similar to Weekly events, the times can be specific or
relative to sunrise or sunset. Define one-time events using the Scheduler > One Time Events screen.

22 www.bannerengineering.com - Tel: 763.544.3164



N

IS

DXM Configuraton Tool v3

L (BT LEEOSVELTEY | One Time Events | JBIIGENR

‘Aﬂd One Time Event ‘ ‘ Delete Last Eveﬂll

Register Mapping ~ Register Number il Mone Start: 1 at

Event Definiion
Action Rules Start Value: 1 % Startat |Relative Time| = | Wednesday, January 20, 2016 3 |» 01:00 3 HH:mm |Before |~ | |Sunrise |«

[ End Value: 0 * Endat |Relative Time| ~| Wednesday, January 20, 2016 % | ~| 1200 2 HH'mm |After ~ | (Sunset |~
Scheduler

Register View

01/20/2016 DUSK+720

01/20/2016 DAWN-60 End: 0 at

Settings

Click on Add One Time Event.

A new one-time event is created.

Click on the arrow to expand the parameters into view.

The user-defined parameters are displayed.

Name your one-time event by clicking on the name link and entering a name.
Enter the local register.

Enter the starting time, date, and starting value for the local register.

Enter the ending time, date, and ending value for the local register.

2.5.3 Create a Holiday Event

Use the Scheduler > Holidays screen to create date and/or time ranges that interrupt weekly events.

2.
3.
4.

e e s Weekly Events | One Time Events

[Add Holiday | | Delete Last Hoiiday |

Register Mapping (IS New Holiday (S5 Wednesday, January 20, 2016 12:00 AM 3 | v IEIH Wednesday, January 20, 2016 12:01 AM % | v

Action Rules

Scheduler

Register View

Setlings

Click on Add Holiday.
A new rule is created.

Enter a name your new holiday rule.
Select the start date and time for the new holiday.
Select the stop date and time for the new holiday.

2.5.4 Create a Dynamic Schedule

The Dynamic Scheduler allows the user to adjust the running event schedule without reloading a full configuration file. This allows the
user to save multiple event schedules and load the schedules as needed.

To enable the dynamic scheduler, go to the Scheduler > Dynamic Update screen and select Enable Dynamic Scheduler. When the DXM
Controller is sent a new scheduler XML file, it replaces the existing schedule configuration with the new schedule configuration.

To create a default configuration and dynamic schedule, follow these steps.

1

Create the default configuration.

a) On the Scheduler > Dynamic Update screen, select Enable Dynamic Scheduler.
b) Create a default DXM configuration file.

c) Save the XML file and upload it to the DXM Controller.
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2. Create a dynamic schedule.

a) On the Scheduler > Weekly Events screen, create a new schedule of events.

b) On the Scheduler > Dynamic Update screen, save the new schedule by clicking on Save Scheduler update file.
3. Load the dynamic schedule.

a) Connect the DXM Controller to your computer using an Ethernet or USB cable.

b) Click Load scheduler update file.

The dynamic schedule uploads to the DXM Controller and takes effect without the device rebooting.

2.6 Settings

The settings tab defines general parameters, cloud services settings, logging parameters, Script Basic settings, networking and e-
mail/SMS messages settings.

2.6.1 Administration

The DXM Controller manages two passwords that are defined on the Settings > Adminstration screen. Defining a File Protection
password requires a password to be entered before a configuration file or ScriptBasic program file is loaded to the DXM Controller. The
LCD protection password requires the user to enter a password on the DXM LCD to unlock the LCD display of the DXM Controller.

File Protection—Setting a password requires that a user enters a password before loading a configuration file or ScriptBasic file. The
password is stored in the DXM Controller and requires the DXM Controller to be connected to the computer via USB port or Ethernet to
set the password.

LCD Protection—The LCD passcode locks the DXM LCD display menu from operation. A valid passcode must contain 1-9 numbers with
the first number being non-zero. The user has access to the full menu system when the passcode has been entered using the DXM LCD
menu. The user can re-lock the display by selecting the Display Lock menu or the DXM will automatically re-lock the display after 15
minutes with no activity. If the DXM reboots, the device prompts the user for the passcode.

Local Registers General | Cloud Services | Logging § Scripting | Network | Mail and Messaging | abt G2 ENGLEE Notes | 10 Board
'

Register Mapping | Get Device Status | Unknown

LCD passcode 5039 ¢ | Send LCD passcode

Blank LCD passcode

Current admin password
Action Rules
Action |Set/Change admin password l=l

Scheduler

Mew admin password

Verify new password

Register View

Submit

1. With the device connected, click on Get Device Status.
2. The device reports back if it is locked or unlocked.
3. Tochange, set, or clear a password select the appropriate action, fill in the required fields then click Submit.

Reset the Controller if the Password is Lost

If the device is locked and the password is lost, go to the DXM Controller to clear the password. Clearing the password from the
controller also erases the configuration file and all ScriptBasic programs. To clear the password:
1. Remove the power from the device.
Set DIP switch 4 to the ON position.
Disconnect the Ethernet cable.
Apply power to the device.
Immediately after powering up, press and hold the reset button on the processor board.
After 10 to 15 seconds, all LEDs on the processor board flash quickly for a second. All files are erased and the password is
cleared.
Remove the power from the device.
Set DIP switch 4 to the OFF position.
Reconnect the Ethernet cable.
Apply power to the device.
This erases all files from the device.

a s wDd

© o N o
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10. Reload your configuration files.

2.6.2 Cloud Services

Use Cloud Services to define the parameters to send register data to the website.

Local Registers General JLelTRTINEER) Logging | Scripting | Network | Mail and Messaging | Administration | Notes | 10 Board | Reprogram

Web Server
Register Mapping shibickes}Ethoinct_ g Server nameP | pushsensonixnet
Ethemet retries per push interval 5%
- Page fpush.aspx
Action Rules Cell module (CES10 2G CDNJ = Enable Server Mode Hest heades

APN =

Site IDIs |GUID

Scheduler |Clear | bb632080-db30-4019-0605-1 2410013270
Koo ox L= oo e e
Cloud push interval Mone - Initial Push Options
Inchude XML GUID on first push
. Sampile count 12 o |
Settings St |
reneer ki
b
[[] Require Authentication Certificate CN  * sensonix net

Usemame

Password

Send Authentication

Cell Configuration

Select the DXM Controller's cellular modem from the Cell module drop-down list.
e CE910 2G CDMA—A Telit CE910 CDMA cellular modem card that operates on the Verizon wireless network.

e HE910 3G GSM/HSPA—A Telit HE910 3G GSM cellular modem card that operates on various carriers worldwide. The modem
supports 2G GSM if 3G is not available.

e LE910 4G LTE—A Telit LE910 4G LTE cellular modem card that operates on the Verizon LTE network. The modem does not have
a fall back to 3G network.

APN, APN Username, and APN Password are user-defined fields.

Cloud Push

The Cloud Push Interval defines the time interval for cyclical data pushes sent to a webserver or host system. Setting the Cloud Push
Interval to zero disables cyclical push messages. When using pushes created by a threshold rule, the Cloud Push Interval is ignored.

Sample count defines how many times between the Cloud Push Interval to save data. The sample points are saved, then sent at the
next Cloud Push Interval.

For example, with a Cloud Push Interval set to 1 hour and the sample count set to 10, the DXM Controller saves the register data every
6 minutes and pushes all data to the web server every hour.

The Push Port defines the HTTP push data port on the web server. The factory default setting is port 80. Set the port to 443 when you
are using HTTPS.

HTTPS

Selecting HTTPS indicates to the DXM Controller to use TLS (Transport Layer Security) as a sub-layer under regular HTTP application
layering. HTTPS encrypts and decrypts user data to and from the web server. The webserver is required to carry a certificate. Select Use
HTTPS to enable TLS services. Not all servers/communication networks support TLS.

A Certificate CN is required to be associated with one or more domain names, called common name (CN). A single name Certificate CN
is typically www.yoursite.com. A wildcard certificate includes single level sub-domains. The Sensonix certificate CN is a wildcard
certificate; *.sensonix.net. If nothing is entered into this field, the Sensonix CN will be used; *.sensonix.net.

The DXM Controller uses the Network Interface settings to determine where to send cyclic report data, alert messages, or log files.
Selecting Ethernet or Cell also requires setting up the parameters under the Settings > Network tab.

When Cellular is selected, the optional VPN (Virtual Private Network) is available. This requires the private cellular plan and allows for
direct point-to-point communication between the DXM Controller and host system. Enabling VPN forces the DXM Controller to
constantly listen for messages from a host system.
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Network Interface

Ethernet Retries per push interval—Used when pushing HTTP data to a webserver using Ethernet and defines the number of attempts
made to send HTTP data to the web server before it will save the message into a local file to be pushed up at the next push interval.
(default 5)

Push interface—Select Ethernet or Cell from the drop-down list.

Web Server

Under the Web Server section, a Host Header allows for multiple domains to reside at the same server address. Similar to how many
people can share one phone number, dialing one number connects you to the phone but to talk to someone specific you need another
piece of information. This is where the Host Header field is used. An IP address can get you to a server and the Host Header field allows
for multiple domains residing at that server. Not all servers require this field, when left blank the intended target of the push message
will be the server name. The Sensonix website does not require this field.

The Server Name/IP is the webserver address used by the DXM Controller when pushing data to the cloud. Enter the domain name,
demopush.sensonix.net or the IP address 54 .218.39.109 for the Sensonix website. The DXM Controller defaults to using a
public DNS (domain name server) to resolve domain names. To use a specific DNS enter the IP address under the Settings > Network
tab.

Enter the Page that directs incoming data at the web server. (/push.aspx)

From the Site ID drop-down list, select either GUID or User Defined Text. For custom web servers the Site ID string can be changed from
a GUID (Global Unique IDentifier number) to a user defined string of numbers or letters. The user-defined text is a unique site string
defined by the web server when a site is created. Copy the string from the website into this field in the DXM configuration tool.

Users can create up to five Custom HTTP Headers to provide custom information to the web server. The custom headers are sent with
every push to the web server. Custom HTTP Headers are text fields the user can define that will be included in the HTTP header when
the data is pushed to the web server.

When Include XML GUID on first push is selected, the first initial push to the web server includes the configuration file GUID (Global
Unique IDentifier) number. The web server can then verify that the XML configuration file that is loaded into the DXM Controller is the
same as what is loaded into the web server.

Web Server Authentication

Webserver Authentication defines a username and password to be sent to the webserver with every push data set to validate the
sending device before storing any data in the database. If the webserver is expecting login credentials, the DXM Controller must be
programmed with the username and password. This only provides login credentials for authentication to the server; this does not
secure the data payload.

The DXM Controller must be connected to the computer. Select Require Authentication, then enter a username and password. Select
Send Authentication to send the username and password to the DXM Controller to be stored in non-volatile memory. Manually cycle
power to the DXM Controller after the username and password are written to it. The credentials cannot be read from the DXM
Controller.

i Important: After Require Authentication is selected and the username and password are sent to the DXM Controller to be
- stored, go to File > Save to save the XML configuration file. Then send the new XML configuration file to the DXM Controller. If
the configuration file loaded into the DXM Controller does not have Require Authentication selected, the username and
password will not be sent.
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Configure the Cloud Settings

1. To configure the connection to the web server, go to the Settings > Cloud Services screen.

General |[elTLELTEIMY Logging | Scripting | Network | Mail and Messaging | Administration | Notes | 10 Board | Reprogram

Local Registers
ensaner
Register Mapping Rlisakeo) Ethomet_Egy Server namenP | push sensonoc net )
Ethemet retries per push interval 5%
RS (ipush.aspx
Action Rules Cell moduke |CES10 2G CDNJ = Enable Server Mode Host header |

. Site IDis (GUID -
APN Usemame

Scheduler | Clear | bb632980-db3d-4019-b605-1 2410013270
APN Password
Bedett Ve [-losomirre s |
Cloud push interval MNone - Initial Push Options
Include XML GUID on first push
- Sa it 18 [m] l
Settings p o
RN o3 HTTPS
Sk tani
[[] Require Authentication Certificate CN  * sensonix net
Usemame
Password
[send Authentcation)

2. Copy and paste the Site ID.

The Site ID is that long string of numbers and letters from the Sensonix Web Services site.

3. Verify the Server Name/IP is set to push . sensonix.net and the Page is set to /push . aspx for sending to the Sensonix
Web Services site.

4. Set the Cloud Push Interval to a value appropriate for your application.

The Cloud Push Interval determines how often the device pushes the data to the web. The faster the push interval, the more
data is sent to the site. Cellular plans can only push at an interval of 10 minutes or longer, while Ethernet connections can push
at an interval of 1 minute or longer. The Logging Interval specifies how often data is gathered by the device.

For example, if the Cloud Push Interval was set to 15 minutes and the Logging Interval was set to 5 minutes, then during each
data push (every 15 minutes) three sets of data would be pushed to the web.

5. Save the configuration file by going to File > Save.

No spaces or special characters are permitted in file names.
6. With a USB cable connected to the device, go to the Device > Connection Settings menu.
7. Select the appropriate COMM port and click Connect.

E Connecticn Settings

(®)Serial (JTCP/IP

Comm Port: e

Mot Connected

If multiple COMM ports are visible, try each one until the software is able to connect to the device.
8. Go to Device > Send Configuration to the Device to upload the new XML file.

2.6.3 General

Use Settings > General to define the time zone, Modbus Master serial interface, Modbus Slave serial interface parameters, and to
manually enter your GPS coordinates.

www.bannerengineering.com - Tel: 763.544.3164 27



DXM Configuraton Tool v3

Local Registers (e EE ] Cloud Services | Logging | Scripting | Network | Mail and Messaging | Administration | Notes | 10 Board

Register Mapping Current device time e |__Gettime from device | |  Synch PC time with device |
Device timezone (UTC) |Central Standard Time (UTC-06:00) Central Time (1 = |
Action Rules Device observes DST [/
Modbus Stave Communications
Scheduler Default lattude 0 Serial mode RG-485 |~ Serialmode  (RS485 |+
Default longitude ol | | Bavarae 19200 |~ || Basgrate (19200 |~
Register View Acquire using Defauit Latiion | ~ Y None =] | | Pariy (None | =)
Extemal GPS address 03 Communication imeout (Mhmmss ) 00:00:05000 & | |_"Vreless Modbus backbone [m] |
Settings Acquire GPS data every (hhumm:ss) 00:00:00 % Maximum poling rate (Mummcss M) D0:00000.050 &
Send location to cloud O Enable DX80 polling (43 buffer) O
Get device information
Processor information 10 board information
Serial number 000001 Serial number 000318 EEPROM number 177276
Model number SxideModule Model number 000000 EEPROM version  0.1C
Firmware number  fw182124 Firmware number 177275
Version 105 Firmware version 35H

Device Information—Click Get Device Information to have the DXM read and display its serial number, model number, version, and
firmware numbers for both the processor board and the 1/0 board.

Device Time—Sets the time zone offset and displays the current time on the device or sync time with the PC.

GPS Location—Defines the latitude and longitude for the device. The GPS data can be entered manually for fixed assets or by defining
an external GPS unit connected to the master Modbus RS485 bus. Select Send Location to Cloud to report this information to the Web
site.

Modbus Master Communications—Defines the Modbus Master serial port settings on the device (main RS-485 port). The default
communications settings are 19200 baud, no parity, RS485. When changing the communications settings on the DXM Controller, any
devices attached to the bus also need to be changed, including the internal ISM radio. The ISM radio communication parameters should
be changed first using the User Configuration Tool for DX80/Performance radios or the MultiHop Configuration Tool for MultiHop
radios.

* The Communication timeout field defines the length of time (hours:minutes:seconds) reserved for each Modbus master
command to complete. The factory default of 5 seconds should be adequate for most Modbus slave devices and DX80 star
wireless networks. This may need to be lengthened for MultiHop networks with battery powered devices or networks with
many chained repeaters.

« The Maximum polling rate field defines the time interval (hours:minutes:seconds) between Modbus messages. The default is
set to 50 milliseconds. Some Modbus devices cannot communicate at this rate and may require greater than 50 milliseconds.

= Enabling DX80 polling automatically defines DXM Local Registers to be allocated as the DX80 Modbus registers. The DXM
Controller runs a routine to request only changes that the Gateway has received from the Nodes in the system. Any input
changes ?re saved in the corresponding DXM Local Registers. To write DXM Local Register data to the Gateway radio, create
Write Rules.

The Gateway uses local registers 1 through16 and Node 1 uses local registers 17 through 32, etc.

Modbus Slave Communications—Defines the Modbus Slave communications parameters and Modbus Slave ID when the RS-232 flow
control signals are configured as a secondary Modbus serial port. Select Wireless Modbus Backbone to enable the Modbus slave port to
come through a MultiHop HE5 module plugged into the SAM4 processor board (DXM150-S1R2P model only).

2.6.41/0 Board

The DXM Controller 1/0 boards come in various combinations of inputs and outputs. The selection of the base board type can be set to
Manual or Auto detect. When modifying parameters, always read (GET) the parameters first, edit, and then write (SEND) the new
parameters back to the I/0 board.

28 www.bannerengineering.com - Tel: 763.544.3164



DXM Configuraton Tool v3

Local Registers

Register Mapping

GET parameders | | SEND paramiders

o [+ Device Restore

Action Rules

+ Default Conditions and Power Save L» RemapRegisters e
* Flash Patters
Scheduler GET all 10 points | |SEND all 10 poirits
Reqgister View » Univrsal 1 Disabied  NPN Raw Fast GET| |SEND » Diserebe Out 1 Disabled
+ Universal 2 Disabled NP Raw Fast cET| | + Distrete Out 2 Disabled
+ Uriversal 3 Disabied NP Raw Fast GET| |sEnD + Diserete Cut3 Disabled
+ Univrsal 4 Disabled  NPH Raw Fast GET| |sEND + Distrote Cut 4 Disablod

» Universal Cut 1 Disabled 0-20mA

¥ Universal Cut 2 Disabled 0-20mA

Depending upon the amount of parameter data to see, click on one of the following buttons to read the current parameter settings:
e GET all parameters and I0—reads all the I/0 board device level parameter data plus the input and output parameter settings.
e GET parameters—reads only the 1/0 board device parameters. Device level parameters effect the 1/0 board operation in
general and are not specific to I/0 points.
e GET all IO points—reads the parameters for all the inputs and outputs on the I/0 board.
e GET—reads parameters for each individual 1/0 point, from one input or output.
Easeg on the number of changes made to the parameter data select one of the following buttons to write the data to the DXM I/0
oard:
« SEND all parameters and IO—uwrites all the 1/0 board device level parameter data plus the input and output parameter
settings.
« SEND parameters—writes only the 1/0 board device parameters. Device level parameters effect the I/0 board operation in
general and are not specific to I/0 points.
« SEND all 10 points—writes the parameters for all the inputs and outputs on the 1/0 board.
* SEND—writes parameters for each individual I/0 point, from one input or output.

Name

Assign a name to each device to it easier to track the device in the configuration software.

The Name must be less than 18 characters and contain only the standard alpha-numeric characters, the following standard ASCII
characters: *, +, -, /, <, >, or a space.

After making any changes, click SEND parameters to write the changes. The status bar at the bottom of the screen indicates the status
of the process. Green (Communication Status Ready) indicates the process is complete. Red (error) indicates an error. Yellow (Getting
Data) indicates the network is retrieving the requested data.

After making any changes, click SEND parameters to write the changes. The status bar at the bottom of the screen indicates when the
process is complete.
Default Conditions

Default conditions are the conditions under which outputs are sent to their defined default state. These conditions apply to all outputs.

= Default Conditions and Power Save
Ooutorsyne O statup [ Comms Timeout 00.00.00.0 &

[] Out of sync power save

~ Default Conditions and Power Save

% O statup  [] Comms timeout 00:00:00.000 +

When a radio is Out of Sync, it is not communicating with its parent radio. Selecting the Out of Sync condition sets all outputs (on this
device) to their specific default values when this radio has lost its communication link with its parent radio. The default output values
are selected under each of the output parameter sections of this screen.

Selecting Start Up sets this radio's outputs to their default values when this radio is powered up.

A Comms Timeout refers to the communication between the host system and the selected radio (which may be any radio within the
MultiHop network). Selecting Communication Timeout sets this radio's outputs to their selected default values when the host system
has not communicated with this radio within the time specified. Set the communication timeout in seconds.

Selecting Out of sync power save sets the radio to low power mode if the radio is out of sync for more than 5 minutes. The radio wakes
up every 5 minutes to search for a parent radio. This setting is recommended for battery-powered devices.

www.bannerengineering.com - Tel: 763.544.3164 29



DXM Configuraton Tool v3

After making any changes, click SEND parameters to write the changes. The status bar at the bottom of the screen indicates the status
of the process. Green (Communication Status Ready) indicates the process is complete. Red (error) indicates an error. Yellow (Getting
Data) indicates the network is retrieving the requested data.

After making any changes, click SEND parameters to write the changes. The status bar at the bottom of the screen indicates when the
process is complete.

Flash Patterns

Setting the flash pattern establishes an on and off pattern that can be used for a discrete output or switch power.

= Flash Patlard
= Flash Pasem 1
E40rs 1250ms
IEEEEOOO0O0O0D0O0ODOODOCOODOODOOO0OO0OO0O00
1580 200ms
I EEEEOO0O0O0O0D0O0DODDNOCOODOODOOO00O0O00O00
3 230me 3500ms
IEEEHE i:::ii::i:::!'.::l'.:l! 100000000000 0000
500 5240

EEEEEEODODODODOOIDOOOOOOOODOOOOOOn
» Flash Panen 2
¥ Flash Fatiem 3
» Flash Pasem 4

Define Flash Patterns by selecting specific timeslots to turn the output on or off. While originally the flash pattern was designed to turn
on and off an indicator light, the flash pattern can be set for any discrete output or switch power. Each slot represents one frame size,
which may vary from radio to radio. The default frame is 40 milliseconds. Users may configure up to four different flash patterns per
radio device.

In the example shown, Flash Pattern 1 is configured to turn on the EZ-LIGHT for 240 milliseconds, then turn off the light for 1040
milliseconds. To preview the flash pattern, click on the Start Animation button. The EZ-LIGHT graphic flashes on and off in the
programmed flash pattern.

After making any changes, click SEND parameters to write the changes. The status bar at the bottom of the screen indicates the status
of the process. Green (Communication Status Ready) indicates the process is complete. Red (error) indicates an error. Yellow (Getting
Data) indicates the network is retrieving the requested data.

After making any changes, click SEND parameters to write the changes. The status bar at the bottom of the screen indicates when the
process is complete.

Device Restore

Use these commands to restore default settings to the selected device.

~ Device Restore

[] Restore default KO configuration

[[] Restore default system parameters

[[] Re-initialize variables from serial number

Restore Device
|}

To restore default device parameters:

1. Atthe top of the screen, select a MultiHop device.
2. Click on GET All Parameters to get that device's I/0 configuration.
3. Inthe Device Restore section, select the appropriate checkboxes.
« Restore Default I/0 Configuration. Restores default I/0 configuration parameters to the values indicated in the
device's datasheet, such as sample and report rates.
. Regtore Default System Parameters. Restore default system parameters, such as the radio configuration and binding
code.
e Re-Initialize Variables from Serial Number. Restores the default values of all variables calculated from the serial
number. This is not typically recommended.
4. Click on Restore Device to restore the selected default values to your device.

Remap Registers or Register Aliasing

Use the Remap Registers section of the Configure Device screen to map registers to contiguous register locations to optimize Modbus
read/write functions.
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+ Device Restore
~ Remap Registers
Alias Registers (601-616) Register Content (101- 116)
|ceT| |sEND| [cer] [senp|
1 5+ 101 0
2 7% 102 0
3 9% 103 D
4 0% 104 D
5 - 105 D
6 501 % 106 i
7 502 % 107 D
a 1 > 108 D
a 1~ 109 D
10 1 110 D
n 1~ m i}
12 1~ 12 D
13 1 > 113 D
14 1~ 114 D
15 1~ 115 D
16 1~ 116 i}

1. Verify the desired MultiHop Radio Address is selected in Configuration Address.
2. Click the arrow next to Remap Registers.

3. Fill'in the source registers you would like to alias. The Alias Registers rows 1 through 16 are the user-defined entries of
addresses of the registers to alias (rearrange). This alias table is stored in the MultiHop radio register addresses 601 through
616. In the example, source registers addresses 5, 7, 9, 10, 8, 501, and 502 are entered into the table.

The aliased Register Contents are in registers 101 through 116. For this example, when a host system reads Modbus registers 101
through 107 of the MultiHop radio, the register contents come from register 5, 7, 9, 10, 8, 501 and 502.

Inputs

The following parameters are used to configure the inputs.
The input parameters vary, depending on the enabled and available input types.

Input Configuration
Select Enable to turn on this input.

Sample Rate—The sample interval, or rate, defines how often the Sure Cross device samples the input. For battery-powered
applications, setting a slower rate extends the battery life. Set the sample rate/interval in hours:minutes:seconds.

Universal Configuration
After enabling the input, configure the universal input type.
Input Type—Select the input type from the drop-down list.
NPN
PNP
0-20mA
0-10Vv
Thermistor
Potentiometer
Bridge
NPN Raw Fast

Preset Value (Counter)—Enter a number in the selection box and press the Set Value button to write a preset counter value to the
register.

Count on rising values—Select to count on a rising transition.
Count on falling values—Select to count on a falling transition.

Analog Configuration

Enable push on change of state—Enables push registers for this input. When the discrete input changes state, the register value is
pushed to the master radio if this register is configured to be a push register. For analog inputs, use the threshold and hysteresis
parameters to define "on" and "off" points.

Enable register full scale—Turning Fullscale ON sets the entire register range of 0 through 65535 to represent the selected minimum
through maximum input values. With Fullscale turned on, a register value of 0 represents the selected minimum value in microamps (for
current inputs). A register value of 65535 represents the selected maximum value in microamps. For example, a register value of 0is 0
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and the register value of 65535 represents 20 mA (or 20,000 microamps). With Fullscale turned OFF, the register value represents unit-
specific input readings. For units of current (mA), register values are stored as microAmps. Voltage values are stored as millivolts. A
sensor reading of 15.53 mA is stored as 15530.

Signal Conditioning

Delta—The delta parameter defines the change required between sample points of an analog input before the analog input reports a
new value. To turn off this option, set the Delta value to 0. To use the delta function, the push registers must be defined.

Hysteresis and Threshold (Analog)—Threshold and hysteresis work together to establish the ON and OFF points of an analog input. The
threshold defines a trigger point or reporting threshold (ON point) for a sensor input. Setting a threshold establishes an ON point.
Hysteresis defines how far below the threshold the analog input is required to be before the input is considered OFF. A typical
hysteresis value is 10% to 20% of the unit’s range.

- In the example shown, the input is considered on at 15 mA. To consider the input off
at 13 mA, set the hysteresis to 2 mA. The input will be considered off when the value

ON paint is 2 mA less than the threshold.

Input Value
1

Median Filter—When the median filter is turned on, three samples are taken for each analog sensor reading. The high and low values
are discarded and the middle value is used as the analog value. Set to zero (0) to turn off the median filter. Set to one (1) to turn on the
median filter.

Sample High and Sample Low—For analog inputs, the sample high parameter defines the number of consecutive samples the input
signal must be above the threshold before a signal is considered active. Sample low defines the number of consecutive samples the
input signal must be below the threshold minus hysteresis before a signal is considered deactivated. The sample high and sample low
parameters are used to avoid unwanted input transitions.

Tau Filter—Set to zero (0) to turn off the tau filter. Set to 1 (weakest filter) through 6 (strongest filter) to turn on the tau filter. (In the
DX80 products, the Low Pass Filter is a combination of the median filter and the tau filter.)
Temperature Settings

Enable full scale (Temperature)—Turning Fullscale OFF sets the register range of 0x8000 (-32767) through Ox7FFF (+32768) to
represent the range of input values. With Fullscale turned OFF, a register value of 1450 represents 72.5 degrees (register values =
temperature x 20). With Fullscale turned ON, users can specify the register minimum and maximum range of values. These min/max
values are represented in the register as 0 (min) and 65535 (max).

Temperature resolution—Select high to store temperatures values in the registers as the measured temperature x 20. Set to low to
store temperature values in tenths of a degree (measured temp x 10). For example, if the measured temperature is 20.5 degrees,
turning temperature scaling to high stores the temperature value as 410 while use low resolution stores the temperature as 205.

Units—Select either Celsius or Fahrenheit for your temperature readings.

Outputs

The following parameters are used to configure the outputs, including the switch power outputs.

The output parameters vary, depending on the enabled and available output types. To begin configuring your outputs, Enable the
output.

Discrete Output

Default Output Value—Select the default output value. When the selected default condition occurs and Hold Last State parameter is
set to OFF, this output is set to the selected default output value (e.g. out of sync, communication timeout, start up).

Use Flash Pattern—To use a programmed flash pattern, set the Enable Flash Pattern to ON, then select the appropriate flash pattern
from the drop-down list. The flash patterns are defined in the Device Parameters section of this screen. Select from one of the four user-
defined flash patterns. Set the flash patterns in the Device Parameters section of this screen.

Hold Last State—Retains its last value during the selected default condition (out of sync, communication timeout, start up).

Switch Power Output

When linking a switch power output to a specific input, select the Enable checkbox and set the Enable default state to OFF. Use the
settings for the specific input to link the switch power output and set the voltage and warm-up time.
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For continuous power, set the voltage on this screen and set the default state to ON. Verify the default "start-up" conditions are set in
the device parameters screens.

Enable default state—When enabled, this switch power output remains on during the selected default condition (e.g. out of sync,
communication timeout, start up). When disabled, the switch power cycles off during the selected default condition.

Hold Last Voltage—When set, the switch power output retains its last value during the selected default condition (e.g. out of sync,
communication timeout, start up).

Use Flash Pattern—To use a programmed flash pattern, set the Enable Flash Pattern to ON, then select the appropriate flash pattern
from the drop-down list. The flash patterns are defined in the Device Parameters section of this screen. Select from one of the four user-
defined flash patterns. Set the flash patterns in the Device Parameters section of this screen.

Voltage—To set a voltage for the switch power output, select a value. When configured for continuous voltage output, this switch
power output no longer cycles on, warms up the sensors, then cycles back down. Because the output voltage remains constant,
continuous voltage is typically used with solar power installations.

Universal Out

After enabling the output, configure the universal output type.

Output is—Select the output type from the drop-down list.
0-20mA
0-10V

Enable register full scale—Turning Fullscale ON sets the entire register range of 0 through 65535 to represent the selected minimum
through maximum input values. With Fullscale turned on, a register value of 0 represents the selected minimum value in microamps (for
current inputs). A register value of 65535 represents the selected maximum value in microamps. For example, a register value of 0is 0
and the register value of 65535 represents 20 mA (or 20,000 microamps). With Fullscale turned OFF, the register value represents unit-
specific input readings. For units of current (mA), register values are stored as microAmps. Voltage values are stored as millivolts. A
sensor reading of 15.53 mA is stored as 15530.

Hold last state (output)—Retains its last value during the selected default condition (out of sync, communication timeout, start up, etc).

H-Bridge Configuration
Enable this output and the H-Bridge configuration to configure its parameters.

Use Flash Pattern—To use a programmed flash pattern, set the Enable Flash Pattern to ON, then select the appropriate flash pattern
from the drop-down list. The flash patterns are defined in the Device Parameters section of this screen. Select from one of the four user-
defined flash patterns. Set the flash patterns in the Device Parameters section of this screen.

Voltage—Voltage required to activate the h-bridge and latching solenoid.

Cap warmup time (hours:minutes:seconds)—Similar to the switch power warm-up time, the h-bridge capacitor warm-up time is the
time allotted to charge the capacitor used to activate the h-bridge and latching solenoid.

Switch time (hours:minutes:seconds)—Time needed to activate the h-bridge and latching solenoid.

2.6.5 Logging

Use Settings > Logging to define the local logging setup for the on-board SD card of the DXM Controller. Up to three cyclical logs and
one event log can be defined for threshold events. Click on the arrow to the left to expand the log configuration parameters.

The string length limit for each line in the Log file is 1,000 characters. Lines typically start with the time stamp followed by the values of
each saved register. Discrete values (0/1) are short, but analog values could be up to 10 characters each. Taking an average of 6
characters for each value stored, the practical limit will be about 160 registers per log file.

General || Cloud Services JIELBIIsIl Scripting | Network | Mail and Messaging || Administration

Local Registers

Log File Management

Register Mapping r—
Save Selected
Delete Selected

Action Rules

Data Log Configuration

Scheduler

Clear Logs: |Daily at midnight UTC - Expand All

Register View () Event Log

() Data Log 1

() Data Log 2

) Data Log 3
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The data log configuration parameters define the log file name, size, and what to do when the size is exceeded. Files can be sent via
email when full.

View, save, or delete files stored on the micro SD card using the Log file Management section. The DXM Controller needs to be
connected to a PC for these features to operate.

HTTP log files are saved to the SD card to save data when the connection is down and the DXM Controller cannot connect to the
webserver. If Enable Log is not selected, the DXM Controller will not save any data in failed transmissions. By default, Clear HTTP Logs is
set to erase the HTTP log files daily to limit the number of log files saved to the SD card.

H Data Log Configuration

Clear HTTP logs: |7 days l=) EID&'ICINI'

« ) Event Log
) Data Log 1
+ | Data Log 2

«) Data Log 3

Create an Event Log or Data Log

Use the Event Log to track data only when the contents of the specified registers reaches the defined value. The Data Logs record the
contents of the selected register at the defined rate.

(%) Enable Log
T ——
[] Timestamg each kg entry
Record times in [x] Local time Log file options | Save when max file size reached 1=
[JuTC time

Maxfilesize 100 = kB

Fibe name | EveniLog Reid

Recipient(s)
[ Disregard scale and offset when saving data
Number of gecimal digits to display in log [ Subject
Only log when register o

Message

[>] Enatile Log

Format and log tri
[3€] Timestamp each kog entry
Record tmes in (%] Lacal time Log file options | Email and save when max file size reache| = |

DJuTC time Maxfiesize 15 5 kB
File name | LogFilet bt -
| Recipient(s) | myemal@sensonix com |

Log rate (hhcmm:ss) 00:00:30 %
Log file header styie (Tt | =] Subject |':’:'"“'L""F"e |
[[] Disregard scale and offset when saving data (
Mumber of decimal digits to display inlog =~ 0 * Masaage | |
Ony log when register o

1. Select Enable Log to enable the log file creation. The register data to be saved in the log is defined under the Local Registers
tab.
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2. Select Timestamp each log entry to date/time stamp each log entry. Select whether you want the time stamps to be in local
time or UTC time.
The local time is determined from the device's time zone selection under on the Settings > General screen.
3. Name your Event or Data Log.
A date/time stamp is added to the end of the user-defined File Name then stored on the Micro SD card. New files will be
created with a new date/time stamp.
4. Select whether or not you want to Disregard scale and offset when saving data for the register or apply the scale and offset
defined on the Local Register Configuration screen.
Local Registers 1 through 845 are integer registers and are always stored as integers. Floating point Local Registers 1001
through 2000 are stored as floating point numbers.
Define the Number of decimal points to display in log (floating point data log only).
Define the Email Parameters for sending a log file when the log file is full.
For cyclical log files (log1-log3), specify the Log Rate.
Set the Maximum File Size before the DXM Controller creates a new file. When emailing log files, keep the file sizes below 50
KB.
9. Select from the following Log file options.

o N oo

« Save when max file size reached—Save the log file to the internal DXM SD card when the defined Max file size is reached.
The user must retrieve the file.

= Save when register is non-zero—Save the log file to the internal DXM SD card when the defined Local Register is set to a
non-zero value. The Local Register can be controlled by Action Rules, ScriptBasic, Scheduler, or Website. The user must
retrieve the file.

« Save Daily—The log file will be saved daily at 00:00 UTC time. The user must retrieve the file.

« Email and Save when max file size reached—Email and save the log file to the internal DXM SD card when the defined Max
file size is reached. You may define up to three recipients to receive the email. Define the SMTP parameters on the Settings
> Network screen.

« Email and Save when register is non-zero—Email and save the log file to the internal DXM SD card when the defined Local
Register is set to a non-zero value. The Local Register can be controlled by Action Rules, ScriptBasic, Scheduler, or Website.
You may define up to three recipients to receive the email. Define the SMTP parameters on the Settings > Network screen.

= Email and Save Daily—The log file will be emailed and saved daily at 00:00 UTC time. You may define up to three recipients
to receive the email. Define the SMTP parameters on the Settings > Network screen.

10. Enter the Recipient email address, Subject, and Message for the log file.
You may define up to three email recipients, separated by commas.

2.6.6 Mail and Messaging

The DXM Controller can email alarm conditions using Threshold rules and can email internal log files when the log files are full. The DXM
Controller must have an Ethernet or cellular network connection for e-mail alarm conditions.

Local Registers General | Cloud Services | Logging | Scripting | Network JEIETEGLEREELELLWEE Administration | Notes

Register Mapping SMTP server | smtpmail visi.com [3] Enable SMTP authentication
SMTP server port 587 % User name | device@sensonic.com
. @ No encryption Password | sxiemail1] |
Action Rules (U Situational encryption
Send SMTP Password
Scheduler ~) E-Mail Recipients
» E-mail Recipient 1 Address |

» E-mail Recipient 2 Address

Register View

» E-mail Recipient 3 Address

. » E-mail Recipient 4 Address
Settings
*» E-mail Recipient 5 Address

+ E-mail Recipient & Address

+ E-mail Recipient 7 Address |

» E-mail Recipient 8 Address

» E-mail Recipientd  Address |

» E-mail Recipient 10  Address
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E-Mail Recipients—Enter the list of email addresses to send message and alerts to. Include the subject line and message.

Mail Server Settings—The server settings specify a SMTP (Simple Mail Transfer Protocol) server as well as provide the login credentials
to the SMTP mail server. The SMTP server port defines where to send the e-mail message for submission. Port 25 or 587 is for typical
sending e-mail. Some servers are set up to reject all messaging on port 25, but valid users authenticating on port 587 are allowed to
relay mail to any valid address. The user can define three email recipients. For mailing larger groups, create groups on the mail server.
Define whether or not to use encrypted (secure) communications with the SMTP server. If your SMTP server does not require an
encryption connection, select No encryption. If your SMTP server can select or de-select encryption as the connection between the
SMTP server and client is negotiated, select Situational encryption. If you enable authentication, you must enter the user name and
password and click Send SMTP Password. This password is not stored in the XML configuration file.

SMS Recipients—Enter the list of people to send text messages to. Note that each cell phone server provider may have a slightly
different address to send text messages to. Enter the message.

2.6.7 Network

Use the Network screen to define the Ethernet connectivity settings, Cellular firewall settings (for VPN), and DNS settings.

Any network parameters adjusted using the LCD Display screen override the settings in the XML configuration file. The user must reset
the network LCD setting on the LCD display before the network parameters in the XML configuration will be used.

Local Registers General | Cloud Services || Logging | Scripting JIENA31 Mail and Messaging | Administration

Cumrent Device IP Cell Firewal
o - IP Address 0.0.00 11 fir I A
Register Mapping Cell firewall IP address 0.0.0.0
Subnet 0.0.00
1l firewall ask 255,255,255
G address 0.0.00 Cell firewall netmas! 255.2 55.0
Actonules | euu oo
| Get Settings from Device | | | (] Enatie UDP console
~ Ethernet Connection Acquisition
Scheduler ecn s
Connection retry 5%
DHCP | =
= Connection retry wait 00:00:10.000 3
Register View -
g IP address 0.00.0 Mao delay between retries 00:01:00.000 %

Subnet 255.255.255.0 ~ Cellular Connection Acquistion
Se“'"gs Galeway address 0.0.0.0 Colnecaoniay, 53

C retry wait 00:00:10.000 %
N oo 000010 %
Primary ONS IP address 0.000 Watchdog timeout 00:00:10.000

Primary cell DNS IP address 0.0.00

|
Secondary DNS IP address 0.0.0.0 |
|
|

*|f there are no valid entries for a section, the firewall
is left open for that category of messages.

Secondary cell DNS IP address | 0.0.0.0

| Phone Number | Add| | Remave |

" Open to all SMSs

(s e
Open to all IPs

| Email Agaress |Add] | Remove |
Open to all Emails

Cellular Firewall and Cellular Software Firewall

The cellular modem has a built-in firewall to restrict which host(s) communicates with the DXM Controller using a private network.
Define an IP address for a single host connection or use the netmask to create multiple IP connections (0.0.0.0 is open to any IP
address).

Select Open software firewall to accept incoming messages on a cellular connection. If Open software firewall is selected and there are

no entries present, the software firewall allows all traffic. Entries within the firewall settings will only allow the devices specified to
communicate with the DXM Controller.

Current Device IP Settings

The current IP address (when connected via Ethernet) can be read from the device or by using the LCD menu on the DXM Controller.
Click Get Settings From Device when the device is connected via the USB port.

36 www.bannerengineering.com - Tel: 763.544.3164



DXM Configuraton Tool v3

DNS

The DXM Controller defaults to using a public DNS service to resolve domain names. Enter the IP address of a primary and secondary
DNS server to select a particular DNS server.

The DXM Controller defaults to using the carrier DNS service. To redirect the DXS requests to a different DNS service, enter a primary
and secondary cell DNS.

IP Address

Select a static IP address or select the automatic assignment of an IP address by selecting DHCP from the drop-down menu. If Static IP is
selected, enter the IP and subnet addresses.

You can also enter static IP addresses using the DXM Controller's LCD menu system. Entering IP Addresses using the menu system
overrides the IP addresses in the XML configuration files. Clear the IP addresses in the menu system to use the IP address in the XML

configuration file.

Network Parameters

The Network Parameters define certain aspects of the user selected network, cellular or Ethernet, within the DXM Controller. In most
cases, the factory default parameters are sufficient for typical applications and do not need to be changed.

Ethernet Connection Acquisition—These parameters govern the operation of the DXM when it tries to connect to an Ethernet network.

e Connection Retry—Defines the number of attempts to join an Ethernet network (default 5). Only use this parameter with DXM
Controller firmware later than version 1.0. Typical settings are 0 through 5 seconds.

e Connection Retry Wait—Defines the amount of time in seconds to wait between the first and seconds retries. For every failed
attempt to connect to the network the wait time increases by a multiple of the wait time. For example, if the wait time is 5
seconds, the delay between the first and second retry will be 5 seconds. The next delay is 10 seconds, then 15 seconds, then 20
seconds, up to the maximum time specified. Only use with DXM Controller firmware later than version 1.0. Typical settings are
0 through 5 seconds.

* Max Delay between Retries—Defines the maximum amount of time to wait between retries. After every failed attempt, the
wait time is increased by the original retry wait time until it reaches the Max Delay between Retries.

Cellular Connection Acquisition—Defines the interaction with the wireless network when trying to establish a connection. The default
parameters should not need to be changed.
e Connection Retry—Defines how many attempts are to be made to create a connection with the wireless network.
* Connection Retry Wait—When a cellular connection fails, the Connection Retry Wait parameter defines how long the system
waits until it attempts to create another cellular connection.

The following Cellular Server Mode parameters only apply to DXM Controllers using a cellular network connection in Server Mode.
Server Mode turns on the cellular modem continuously to allow for connections from a host system to the DXM Controller. Do not
configure the DXM Controller to send push data automatically in Server Mode.

e Activity Timeout—An internal setting on the cellular modem that watches the incoming activity. If there isn't activity coming
into the cellular modem for the specified amount of time, the connection closes and the device returns to listening mode. This
catches the issue with the host system dropping a connection but the cell modem not aware of the dropped connection. Always
set the Activity Timeout parameter to a time longer than the expected polling rate. If the polling rate is 1 hour this setting
should be greater than 1 hour (e.g. 4000 seconds). The factory default setting is disabled (0).

e Watchdog Timeout—Used in an application routine running in the DXM processor. If there is no incoming cellular traffic within
the watchdog time period, the cell modem resets. The Watchdog Timeout should be greater than the Activity Timeout; the
watchdog routine is a failsafe mechanism to detect if the cellular modem is left in a bad state from the wireless network. The
factory default setting is disabled (0).

2.6.8 Notes

Use the Notes screen to enter informational text about the configuration file or notes specific to the application.

The Notes screen can save up to 4096 characters of alphanumeric characters and some special characters (~! @ #$" () _-=+?/}]
{[)- The notes are stored in the beginning of the XML file.

2.6.9 Scripting

The DXM Controller can run one ScriptBasic program.
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General | Cloud Services || Logging | iSleiguiils}§ Network § Mail and Messaging | Administration

Script File Management

Local Registers

Register Mapping

Upload script Refresh List
Save Selected
Delete Selected
Add Selected to Startup

Script to be run at startup: Clear Startup Script
Register View
Script Basic options

[] TCP Server Enabled Port: 0
Settings
[] TCP Client Enabled Port: 0 % |IPAddress 0.0.00

[J UDP Enabled Port: 0 % IPAddress 0.0.0.0

Action Rules

Scheduler

<>

Under the Scripting tab, save, load or delete script files on the DXM Controller. Select a ScriptBasic file from the current ScriptBasic files
window and select Add Selected to Startup Scripts to define which program should be run at boot time. Save the XML configuration file
before loading to the device. A reboot is required to start a new script program.

To upload files:

1. Click Upload. A pop-up box appears.
2. Select the pull-down menu to select the file types: .sh, .esb or *.*,
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Corporate Headquarters

Address:

Banner Engineering Corporate

9714 Tenth Avenue North
Minneapolis, Minnesota 55441, USA

Europe

Phone: +1 763 544 3164
Website: www.bannerengineering.com

Address:

Banner Engineering EMEA
Park Lane Culliganlaan 2F
Diegem B-1831, Belgium

Turkey

Phone: +32 (0)2 456 0780
Website: www.bannerengineering.com/eu
Email: mail@bannerengineering.com

Address:

Banner Engineering Turkey

Barbaros Mah. Uphill Court Towers A Blok D:49
34746 Bat Atasehir Istanbul Turkiye

India

Phone: +90 216 688 8282
Website: www.bannerengineering.com.tr
Email: turkey@bannerengineering.com.tr

Address:

Banner Engineering India Pune Head Quarters

Office No. 1001, 10th Floor Sai Capital, Opp. ICC Senapati Bapat Road
Pune 411016, India

Mexico

Phone: +91 (0) 206 640 5624
Website: www.bannerengineering.co.in
Email: salesindia@bannerengineering.com

Address:
Banner Engineering de Mexico Monterrey Head Office

Edificio VAO Av. David Alfaro Siqueiros No.103 Col. Valle Oriente C.P.66269

San Pedro Garza Garcia, Nuevo Leon, Mexico

Brazil

Phone: +52 81 8363 2714 or 01 800 BANNERE (toll free)
Website: www.bannerengineering.com.mx
Email: mexico@bannerengineering.com

Address:

Banner do Brasil
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Campos Eliseos, Jundiai - SP, CEP.: 13208-761, Brasil

China

Phone: +1 763 544 3164
Website: www.bannerengineering.com.br
Email: brasil@bannerengineering.com

Address:

Banner Engineering Shanghai Rep Office

Xinlian Scientific Research Building Level 12, Building 2
1535 Hongmei Road, Shanghai 200233, China

Japan

Phone: +86 212 422 6888
Website: www.bannerengineering.com.cn
Email: sensors@bannerengineering.com.cn

Address:

Banner Engineering Japan

Cent-Urban Building 305 3-23-15 Nishi-Nakajima Yodogawa-Ku
Osaka 532-0011, Japan

Taiwan

Phone: +81 (0)6 6309 0411
Website: www.bannerengineering.co.jp
Email: mail@bannerengineering.co.jp

Address:

Banner Engineering Taiwan

8F-2, No. 308 Section 1, Neihu Road
Taipei 114, Taiwan

Phone: +886 (0)2 8751 9966
Website: www.bannerengineering.com.tw
Email: info@bannerengineering.com.tw
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3.2 Banner Engineering Corp. Software Copyright Notice

This software is protected by copyright, trade secret, and other intellectual property laws. You are only granted the right to use the software and only for the purposes described by Banner.
Banner reserves all other rights in this software. For so long as you have obtained an authorized copy of this software directly from Banner, Banner grants you a limited, nonexclusive,
nontransferable right and license to use this software.

You agree not to use, nor permit any third party to use, this software or content in a manner that violates any applicable law, regulation or terms of use under this Agreement. You agree that
you will not reproduce, modify, copy, deconstruct, sell, trade or resell this software or make it available to any file-sharing or application hosting service.

Disclaimer of Warranties. Your use of this software is entirely at your own risk, except as described in this agreement. This software is provided "AS-1S." To the maximum extent permitted by
applicable law, Banner, it affiliates, and its channel partners disclaim all warranties, expressed or implied, including any warranty that the software is fit for a particular purpose, title,
merchantability, data loss, non-interference with or non-infringement of any intellectual property rights, or the accuracy, reliability, quality or content in or linked to the services. Banner and its
affiliates and channel partners do not warrant that the services are secure, free from bugs, viruses, interruption, errors, theft or destruction. If the exclusions for implied warranties do not
apply to you, any implied warranties are limited to 60 days from the date of first use of this software.

Limitation of Liability and Indemnity. Banner, its affiliates and channel partners are not liable for indirect, special, incidental, punitive or consequential damages, damages relating to
corruption, security, loss or theft of data, viruses, spyware, loss of business, revenue, profits, or investment, or use of software or hardware that does not meet Banner minimum systems
requirements. The above limitations apply even if Banner and its affiliates and channel partners have been advised of the possibility of such damages. This Agreement sets forth the entire
liability of Banner, its affiliates and your exclusive remedy with respect to the software use. You agree to indemnify and hold Banner and its affiliates and channel partners harmless from any
and all claims, liability and expenses, including reasonable attorney's fees and costs, arising out of your use of the Services or breach of this Agreement (collectively referred to as “Claims").
Banner reserves the right at its sole discretion and at its own expense, to assume the exclusive defense and control of any Claims. You agree to reasonably cooperate as requested by Banner in
defense of any Claims.
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