Suréﬁ . Machine Monitoring/OEE
Cross Solutions Guide

solutions

Guide Features and Benefits

MACHINE MONITORING Monitor machine inputs with up to four tower light modules (on up to 24 tower lights) and eight states (flashing or
solid for each light module)

UP TIME Track cumulative ON time for each light module for both flashing or solid independently

EVENT COUNTERS Count the number of times each light module transitions from OFF to ON for both flashing or solid independently

PART COUNTING Count parts produced or rejected using internal 32-bit register in TL70

REMOTE MASTER LIGHT Use a master light to show combined status of all light modules

TIME STAMPED LOGGING Time stamped logging of light statuses, timers, counts, and part counts to a local SD memory card.

SMS TEXT/EMAIL ALERTS Generate SMS text and/or email alerts based on specific events

EFFICIENCY METRICS Produce efficiency metrics with provided data (Avg. Availability, Production Speed, Production Quality, etc.)

CLOUD MONITORING Push data to Cloud Webserver or PLC (via LAN or Cellular connection) for remote viewing, alerting, and logging.

Using a TL70 Modular Tower Light with a wireless radio base improves machine monitoring and overall equipment effectiveness (OEE)
by expanding available data beyond the local indication a standard tower light provides. Beyond local indication, each TL70 can provide
remote status of each light module, track the cumulative time ON for each light module, count the number of events each module
has transitioned from the OFF to ON state, and count parts. This system provides the information necessary to react quickly to system
changes and drive efficiency improvements based on data that was previously unavailable.

Equipment

Model Description

TL70DXN9XXXQ or TL70DXN2XXXQ (XXX is EZ-LIGHT TL70 Wireless Modular Tower Light; select either 900

any combination of light colors) MHz or 2.4 GHz ISM radio to match the DXM100

DXM100-B1C1R1 or DXM100-B1C1R3 DXM100 Wireless Controller with Cell; select either 900 MHz or 2.4
GHz ISM radio to match the TL70

A PDF of this Solutions Guide is available at https://goo.gl/Vuw4wg
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The following guide demonstrates how to bind the wireless tower lights to the DXM and load a preconfigured XML file and script to
collect data from up to 24 wireless tower lights. The XML file only requires some minor modifications to be customized for any site.

Step 1: Bind the System and Assign Addresses

Binding the TL70s to the DXM100 establishes a secure connection between them and assigns a specific network address to each TL70 in
the wireless network.

1.

No vk~ wnN

8.
9.

Apply power the TL70s.
TL70s require a constant power source to maintain wireless communications with the DXM, unlike typical tower lights that use
only machine power when lighting.

Apply power to the DXM.

On the DXM: Use the arrow button to select the ->ISM Radio menu on the DXM's LCD. Press Enter.

Select ->Binding and press Enter.

Select Bind to > 1 (the first Node) and press Enter.

On TL70 Node 1: Remove the base section by grasping the lighting modules and twisting the base clockwise.

Triple-click the binding button.

The LED flashes four times after it binds to the DXM. This Node is now bound as Node ID 1.
Label the TL70 for future reference.

DIP Switches

!

Binding
Push Button

Reconnect the TL70’s base to its light modules.
On the DXM: Press Back to return to the main menu.

10. To bind additional TL70s, select Bind to > 2 and press Enter.
11. On TL70 Node 2: Repeat steps 6 through 9.

If more TL70s are being used in the system, continue binding in the same fashion until all TL70s are bound to the DXM with each having
their own Node ID.

When you are finished binding, press Back on the DXM until the DXM returns to the main menu.

Step 2: Run a Site Survey

Verify the wireless connection between your TL70s and the DXM by running a site survey on the DXM100.

1.

2.
3.
4

On the DXM: Use the arrow buttons to select the ->ISM Radio menu. Push Enter.

Select the ->Site Survey submenu, and press Enter.

Select each Node ID within the system to verify the wireless connection between the Node and the DXM.
When you are finished running the site survey, press Back twice to return to the main menu.

Step 3: Wire the TL70

Light Modules

Each TL70 requires its own dedicated 12-30 V dc power supply. The light modules also need to be triggered by the machine being
monitored and wired as shown. The 5-pin base allows a maximum of three modules and the 8-pin base allows for four modules and
part counting. A flashing condition is automatically detected as a separate state as long as it is between 0.8 Hz and 6 Hz.
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Part Counting
To use the TL70 for part counting, follow these steps:

1. Wire a sensing device with a PNP (sourcing) output (12—-30 V dc), such as the QS18, QS30, Q4X, etc, into pin 8.
2. Change DIP switch 3 in the TL70 light base to the ON position.

When using the part counter, the measured signal must be greater than or equal to 25 ms.

The total counts are stored in the TL70 and reported to the master radio. A lost radio link or interruption in the radio signal to the DXM
does not interrupt the part counting. As soon as the radio link re-establishes, the correct count is reported from the TL70 to the DXM.

DIP Switches

J U_ Correct
_I_l_l_l_l_l_l_l_ Incorrect

Binding
Push Button

t=0 25ms 50ms 75ms 100 ms

Step 4: Configure the System

To customize the system to an actual application, some basic modification to the template files is necessary. There are two files
uploaded to the DXM: the XML file sets the DXM’s initial configuration and the ScriptBasic file reads the status of light modules, controls
the counting of each light, establishes a reset function for each TL70s timers and counts, and organizes the information in logical and
easy to find registers in the DXM.

Loading these files and making adjustments requires the use of Banner’s DXM Configuration Tool software and the machine monitoring
files available via in the links below.

1. Download the preconfigured files. (https://goo.gl/fpgOtF)

2. Extract the ZIP files into a folder on your computer. Note the file location.

3. Connect the DXM, via the USB cable supplied with the DXM, to a computer containing the DXM Configuration Tool software or
download the software and install it on a computer.

4. Launch the software.

5. Load the Machine Monitoring file (TL70) by going to the File > Load menu and choosing the configuration files.

6. Connect the software to the DXM by going to the Device > Connection Settings menu. Select Serial and then select the COM
port that the USB cable is plugged into. Click Connect. If you are unsure which COM port is being used and multiple ports
appear, attempt to connect to each one until you are successful.

7. Upload the Machine Monitoring file (TL70) by going to the Settings > Scripting screen. Click Upload Script and select the file.

8. Select the uploaded file in the window to the right of the Upload Script button. Click Add Selected to Startup; the DXM will
run this script every time it restarts.

9. Save the XML file using the File > Save menu. Save the XML file any time the XML has been changed because the tool does not
autosave.

Banner Engineering Corp. ® Minneapolis, MN U.S.A
www.bannerengineering.com e Tel: 763.544.3164
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Optional Steps: Customize the XML file

1. Within the DXM Tool, click on the Local Registers tab on the left side of the tool then click on Local Registers in Use tab along
the top.
2. Rename the Tower Lights using the text boxes within the Register Name column. Because there are 25 registers per tower

light to accommodate up to four modules per tower light, a timer for each module (flashing and solid), and a count for each
module (flashing and solid), copy and paste names for efficiency.

To display the tower light status on the website you must change the Web column drop-down lists to Read for each tower light
module information piece (status, Mins ON, and count) that you would like to appear on the website.

Local Register Configuration | Modify Multiple Registers |IRMEIREMEEEALRVEEIN Protocol Conversion Overview

Local Registers

Constant Cloud = Protocol =
or Timer Reporting LE0 WeD Conversion Log Files

(1t oot s Pors | < AT cre |~ BN on) < M e BN o - BN o~ Bl vore -

Register Name Units Signed
Register Mapping

3. Todisplay the tower light status on the website, change 3 : i ; 3 !
play o g ’ g Local Registers Local Register Configuration JL5GGRN T Reglsters
the cloud permissions.

Modify Registers

a) On the Modify Multiple Registers screen, select

_ _ Starting Register: 1% Ending Register: 300 &
Register Mappin
Change in the drop-down list next to Cloud Permissions . FRES
and Cloud Reporting.
. . Action Rules Name: (Nome |~
b) In the drop-down list to the right, select ON for Cloud constantor . —
Reporting and Read for Cloud Permissions o =
' Scheduler units: (None | 7
c) Set the Starting Register to 1 and the Ending Register Sign type: T
to the value equal to 25 x Numbgr of tower lights in the ER o o S
system (for example, set the ending register 300 for 12 LD Pemissins: (oS
tower Ilghts) Settings Cloud Reporting: |Change |~ | [On
d) Click Change Registers on the bottom right of the Cloud Permissions:  (Change | v  (Hid
section. SD Card Logging: None -
Protocol 1C: MNone -
Host timeout: Mone -
Reset Form Change Registers

4. Configure to Receive Email or Text Alerts
when any of the light modules turn on.

a) Click on the Action Rules tab and expand [t

the ANY Module X ON rules using the arrow

LLEELGIGER ) Register Copy | Math / Logic

{Aud Threshold Rule ‘ { Delete Last Rule |

next to the rule PEIETSETI Vnen register 794 (None) equals 1 setregister 639 (None) fo 0 else setto 0

b) Click on the arrow next to Email/SMS on
State Transition.

When lacal register 794 % None [= - | [Value - 1%

. then set local register number 638 % None to [Value - (10
c) Select the recipient of the SMS and/or e haduler A = 0s

email upon any of the Tower Light’s specific
modules transitioning to ON.

In the example shown, both SMS Recipient
1 and 2 and Email Recipient 1 and 2 will
receive a message if any Module #1 is ON
in the system.

Logging Options
Register View Hysteresis value: 0 2 | | Record the number of minutes | | (] Save Threshold events to cloud

Minimum On time (hh:mm-ss): 00:00:00 that the rule has been true (0| S T TSP aEri
[] Push When Active

Minimum Off time (hh:mmyss): 00-00.00 % | | to register 0z
mimum DO CER) [] After Trigger, set source to D

Setlings

| E-mail/SMS on State Transition

8MS E-Mail
SMS Recipient 1 | [X] E-mail Recipient 1 | [X]
SMS Recipient 2 | [x] E-mail Recipient 2 | [}
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Set up the Ethernet or Cellular Connection

By default, the XML file configures the DXM100 with an Ethernet Push interface with the ability to send emails and push the data
registers to a webserver. The device can also be configured to use a cellular push if the DXM Controller contains a cellular module and
data plan. This section is only necessary if the user wants to receive or display information beyond just the DXM Controller's LCD.

1.

If the DXM will text, email, or push to the cloud webserver, set up the push interface.

a) On the DXM Configuration Tool, go to the Settings > Cloud Services screen.
b) Select the appropriate Push Interface (Ethernet or Cell) from the drop-down list.

Selecting Cell requires a cellular module be installed in the DXM Controller and a wireless plan be set up for sending data.

~ E-mail Recipient 1 - Address: | i mail.com |

The Cloud Push Interval determines how often the DXM pushes the
current status data to the webserver. By default, this interval is set to
zero and should not be changed. The files associated with this guide
are set up to push all data registers when the status of one of the e A |
tower light modules changes or once per hour if no changes occurred. , emairecipient 4 - Adess: |

Subject: | Light Active |

Message: ‘ Light is Active ‘

» E-mail Recipient 2 - Address: |

Change the hourly push rate by modifying the value in register 842, » E-mail Recipient & - Address: |
which is listed in seconds. Note an increase in the push rate increases  * Emai Recipiont6 - Address: |
the data points sent to the website, which could change the number ~ * EmaiRecieni7 - Address: |

» E-mail Recipient 8 - Address: |

of data points needed in your Web Services Subscription. ot - e |
» E-mail Recipie! - ress:
Set up the email and text messages. SMS works only if the DXM has @, ¢ ai recipint 10 - agress | |

cellular module. Expand the Email Recipients and SMS Recipients to e

enter up to 10 email addresses and 10 phone numbers, along witha ==~ [SWo Recient ]

CUStom message‘ Recipient: |7535551234
a) Go to the Settings > Mail and Messaging screen. Message: | Light s Active |

b) All SMTP fields should remain set to their default values, except the
Password field. Enter “sxiemaill” into the password field.

c) Click Send SMTP Password.
d) Click Yes when asked to reboot the device.

Step 5: Save and Load the XML File

When changes are made to the XML file, save the changes. To apply the changes, load the XML file to the DXM.

1.
2.

Save the file by going to the File > Save menu.

Load the file onto the DXM by going to the Device > Send Configuration to Device menu.

Because of the size of the XML file, the file may take up to three minutes to load. Verifying the file is loading by looking at the
Application Status indicator in the status bar.

If the Application Status indicator is red, close and restart the DXM Configuration Tool, unplug and re-plug in the USB cable and
reconnect the DXM to the software. If the Application Status indicator is green, the file upload is complete. If the Application
Status indicator is yellow, the file transfer is in progress.

Connected 10.10.82.134 Active File: TL70_guide1 xmi S 3 Version: 20.41

Connected 10.10.82 134 Active File: TL70_guide1 xmi Version: 2041

Not Connected Active File: TL70_guide1 xml

Banner Engineering Corp. ® Minneapolis, MN U.S.A
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Step 6: Push Information to the Cloud

The DXM100 can connect to the web via Ethernet or an internal cell module to push data from the site to the cloud and displayed on a
website. To enable this capability for remote monitoring and alarms settings, modify the XML file.

The website for storing and monitoring the system's data is https://data.sensonix.net/.

=

Lo ~NL W

[EENY
= O

12.

Connect the DXM to a computer with the DXM Configuration Tool software.

Launch the software and connect to the DXM.

Load the saved XML file.

Go to the Settings > Cloud Services screen.

Visit the Sensonix Web Services website (https://data.sensonix.net/) and log into an existing account or register a new account.
Click + New Site and name your site.

Go to the Settings > Sites webpage.

Highlight and copy the Site ID.

On the DXM Configuration Tool: Return to the Settings > Cloud Services screen and paste the copied ID into the Site ID field.

. Save the XML file (File > Save).
. Upload the file to the DXM (Device > Send Configuration to the Device).

SSENSONIX @ Dashboard ~  [ElHistory v  # Seftings + & Audit ~ 2 Sites ~
‘ Sites ‘ Custom Alarms Backups Users Companies

Edit send XML Get XML site Name site ID LastPush  Method Authentication  PollInterval  Push Interval  Register Estimate
o EEA TL70 Machine Monitoring| c61818c-fe87-400a-810a-44b47874cdor | 13d 2h 18m  Celular  OFF 00:00:00 00:15:00 140160

Subscriptions Products Support FAQ

On the Sensonix Web Services website, click Send XML to Web and select the XML file that was just saved and uploaded to the
DXM.

This creates continuity between the site created on the website with the DXM used in the field. The DXM pushes data to the
website, which can be viewed at any time. Refer to the Sensonix Web Services Instruction Manual to review all the features
available for monitoring, comparing data, and establishing warnings/alarms on the website.

Additional Features

Resetting the Timer and Counts

Each TL70 in the system has a reset register that is available on the face of the DXM’s LCD and via the website. Setting this register to 1
resets all the counts and timers on that particular TL70.

Resetting from the DXM

1.

On the DXM: Use the arrows to select Registers. The registers are labeled TL X Reset (where X is the TL70 Node ID you want to
reset).

Select the appropriate register to reset.
Click the Enter button.
Change the value to 1 then click Enter three times. The reset register automatically returns to zero after the TL70s reset.

6 P/Nb_4437437 RevB
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Resetting from the Website

1.
2.

vk w

6.

Go to the Dashboard > Sites screen.

Click Update Device for the site where the particular TL70 exists.

The Update pop-up window appears.

From the Type drop-down list, select Register.

From the Register Name drop-down list, select the TL70 you want to reset.
Enter 1 into the Value field and click Queue.

Repeat steps 4 and 5 for each TL70 that needs to be reset.

When the next data push occurs, the chosen units will reset. The reset registers automatically return to zero after the TL70s reset.

Creating a Master Light

Local Registers 794-797 are used to OR each module independently for all the TL70s (for example, 794 is 1 when ANY tower light in the
system has module #1 on or flashing).

A master light can be used as one of the 24 in the system to reflect these OR’d statuses.

1.
2.

Local Registers

On the DXM Configuration Tool software: Go to Register Mapping > Write Rules.
Select Add Write Rule and map four registers starting at 794 to slave ID #1 at the four output registers for the Master Light.

The register number for the master light outputs is N x 16 + 9, where N is the Node ID of the master light. The example shows
the setup for the Master Light on Node ID 10 (10 x 16 + 9 = 169).

GEELUTIESS (Write Rules

| Add Write Rule | | Delete Last Rule |

Register Mapping - Master Light PR iocal registers from [IREIIRM through 797 toslave id [JERRY stariing at register TR through 172

Configuring Time Stamped Logging

By default, the files associated with this guide trigger a time-stamped event in the log each time a tower light module changes status or
once per hour if no changes have occurred. Change the hourly log rate by modifying the value in register 842, which is listed in seconds.
Note this also modifies the cloud push rate if it is used.

To setup time-stamped logging, follow these steps.

1.

e W

Go to the Local Registers > Modify Multiple Registers screen.
Click Reset Form.

From the SD Card Logging drop-down list, select Change.
Select Log 1 in the drop-down list that appears to the right.

Set the Starting Register to 1 and the Ending Register to the value equal to 25 x Number of tower lights in the system (ex.
Ending Register 300 for 12 tower lights).
Click Change Registers on the bottom right portion of the section.

Retrieving a Log File

1.

e wN

Connect the DXM to the computer via USB or Ethernet. Connect the DXM Configuration Tool software to the DXM using the
Device > Connection Settings menu.

Go to the Settings > Logging screen.

Click Refresh List.

In the Log File Management window, select the file to save.
Click Save Selected to save the file to a folder on your computer.

Banner Engineering Corp. ® Minneapolis, MN U.S.A
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Local Registers

Local Registers

Description

Module Count

1+25x%x(N-1) Module 1 Status (On/Off/Flash)
2+25%x(N-1) Module 2 Status (On/Off/Flash)
Module Status
3+25x(N-1) Module 3 Status (On/Off/Flash)
4+25x%x (N-1) Module 4 Status (On/Off/Flash)
5+25x(N-1) Module 1 Time On (Minutes)
. 6+25x (N-1) Module 2 Time On (Minutes)
Module Timers
7+25x(N-1) Module 3 Time On (Minutes)
8+25x(N-1) Module 4 Time On (Minutes)
9+25x (N-1) Module 1 Count

10+ 25 x (N—1)

Module 2 Count

11+25%x (N-1)

Module 3 Count

12+25x (N—-1)

Module 4 Count

Module Timers

13+25 x (N—1)

Module 1 Flash Time On (Minutes)

14+25%x (N-1)

Module 2 Flash Time On (Minutes)

15+25x (N—1)

Module 3 Flash Time On (Minutes)

16+ 25 x (N—1)

Module 4 Flash Time On (Minutes)

Module Count

17+25%x (N-1)

Module 1 Flash Count

18+25x (N—1)

Module 2 Flash Count

19+ 25 x (N—1)

Module 3 Flash Count

20+25%x (N-1)

Module 4 Flash Count

Part Count

21+25% (N-1)

Part Count

TL All Modules OFF

22+25x% (N-1)

All OFF Status

23+25%x(N-1)

All OFF Timer

TL RF Connection Status

24+25x (N-1)

Connection Status

25+25x (N-1)

Connection Status Timer

All Off NOR’d 601-624 All Off Status NOR'd
625-648 Read Module 1 Statuses
649-672 Read Module 2 Statuses
Read Rule Module Statuses
673-696 Read Module 3 Statuses
697-720 Read Module 4 Statuses
TL70 Resets 770-793 TL70 Timer and Count Reset
794 Any Module 1 Active
795 Any Module 2 Active
OR’d Alerts -
796 Any Module 3 Active
797 Any Module 4 Active
Read Rule Connection Status 800-823 Read TL Connection Status
Log Timer Constant 842 Time (seconds) for Log and Cloud Push
Log Timer 843 Log Timer
Log Trigger 844 Trigger to Log/Cloud Push

Where N represents the TL70 Node ID.
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