
Overview
This guide provides directions for connecting Banner Engineering's Vibration Monitoring Solution to the Internet using either Banner
CDS or AWS IoT Core.
This solution consists of vibration sensors connected to a DXM Series Controller running a script for setting a vibration baseline and
generating alerts when an asset exceeds thresholds. For more information on the Banner Vibration Solution, please refer to the
Vibration Monitoring Application Guide .
This guide requires that the DXM have firmware version 3.3.4 or newer. To download the latest firmware, check the software section
of the DXM Webpage and use the DXM Configuration Software under Tools > Reprogram to load the latest firmware.

Configure the DXM
Follow these steps to configure your DXM Controller.

1. Download, install, and launch the DXM Configuration Software.
2. Apply power to the DXM Wireless Controller and then connect to your computer using either the USB cable or Ethernet

cable.
Depending on the model of the DXM Wireless Controller you have, your USB and Ethernet ports may be in different places
on the device. Please refer to the manual for your DXM model for more information.

3. In the configuration software, go to the Connect to DXM screen and connect to the DXM:
a) Serial (USB cable) - Choose the Comm Port from the drop-down list and click Connect. Use the refresh button if no

comm port is showing up or working.
b) TCP/IP (if using Ethernet) - enter the IP address of the DXM and click Connect. The computer using the tool and the

DXM need to be on the same network, which means either setting the IP address of the computer to match the DXM in a
static setup or setting the DXM's IP address on its screen under Software Config > Ethernet.

4. Download the Vibration Monitoring Configuration files.
5. Go to File > Open and load the XML file into the configuration software.
6. Go to the Settings > Scripting screen and upload the ScriptBasic file (.sb file).

Figure 1. Scripting screen

7. After the ScriptBasic file uploads, the script name appears in the box next to the Upload file button. Verify the name of the
file matches the file listed in Script to run at startup.

8. Before sending the XML to the DXM, configure your system to use either Banner CDS or AWS IoT Core (see AWS IoT Core
Quick Start Guide on page 4).
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Push Information to BannerCDS
The DXM Wireless Controller can connect to the Web via Ethernet or an internal cell module. The controller pushes data from the
DXM to be stored and displayed on a website.
The Banner platform for storing and monitoring the system's data is https://bannercds.com. The Banner Cloud Data Services
website automatically generates dashboard icons and graphs for the application that is populated onto the Dashboard. Email alerts
can be configured using the Alarms screen.
For more information on creating accounts on and using the Banner Cloud Data Services (CDS) system, please refer to the Banner
CDS Quick Start Guide (p/n 201126) or the Instruction Manual (p/n 178337).

Logging into the Web Service
The web server captures data from the DXM Controller using either a cellular connection or an Ethernet connection. Users collect
and view the data or update and manage the DXM Controller using a web browser.
Within a few minutes of your purchase, you will receive an email with your authorization code and details regarding the data
subscription service. If the authorization code is not received within 10 minutes, please check your spam folder or contact Banner
Engineering at 1-888-373-6767 to obtain the code.
Use both the website and the DXM Configuration Software to set up and configure your data collection. Use the latest version of
your browser (Google Chrome is recommended) and enter the URL: https://bannercds.com. The login page appears.
 

 

Create a New Gateway
After you log into the Banner Cloud Data Services website, the Gateway screen displays. Follow these steps to create a new
monitoring site.

1. Click on New Device in the top right corner of the Overview page.
Create a new device for each DXM Controller that will be sending data to the web server.
A New Device prompt appears.

2. Verify Traditional is selected for the Gateway Type.
3. Enter a Gateway Name.
4. Select the Company from the drop-down menu.
5. Copy the Gateway ID number located within the prompt window.

The Gateway ID number created by the web server is a required parameter in the configuration of the DXM. The Gateway
ID is the address the webserver uses to store the data pushed from the DXM.

6. Upload an XML file by clicking Select File under Update XML. Browse to locate a saved XML.
7. Click Save.

Connect to the Software and Download the Existing Configuration
Follow these steps to connect your DXM to the configuration software and download the existing configuration file from your DXM to
your hard drive.

1. On the computer, download the DXM Configuration Software v4 from the Banner Engineering website and install it.
2. On the DXM: Apply power to the DXM.
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3. Connect the DXM Controller to the computer with a USB cable or skip if the DXM is connected to the same network as the
computer.

4. On the computer: Launch the DXM Configuration Software.
5. From the DXM Model drop-down list, select DXM700.
6. On the menu bar, go to Device > Connection Settings.

• If you are using the USB cable, select Serial, then select the COM port that the USB cable is plugged into. Click
Connect. If you are unsure which COM port and multiple appear, attempt to connect to each one of them until
successful.

• If you are connected to the same network as the DXM, select TCP/IP and enter the DXM IP address. Click Connect.
7. After the DXM is connected to the software, click Device > Get XML configuration from DXM to download the current XML

file.
8. Name and save the file to the computer.

Configure the DXM to Push Information to the Cloud
1. Within the DXM Configuration Software, go to the Settings > Cloud Services screen.
2. Set the Server name/IP to push.bannercds.com.
3. Select the appropriate Push interface to either Cellular or Ethernet.

• To set up Ethernet, use the Settings > Network screen.
• To set up cellular, refer to the Activating a Cellular Modem (p/n 205026) technical note.

4. Verify the Gateway ID is set to GUID.
5. Verify the Push method is set to Cloud Push.
6. Leave the Cloud push interval and Sample count unchanged. The DXM script controls this to push every 5 minutes.
7. In the Web Server section, keep the Site ID is drop-down selection as GUID and paste the copied ID from the webpage into

the Site ID field.

Save and Upload the Configuration File
After making any changes to the configuration, you must save the configuration files to your computer, then upload it to the device.
Changes to the XML file are not automatically saved. Save your configuration file before exiting the tool and before sending the XML
file to the device to avoid losing data. If you select DXM > Send XML Configuration to DXM before saving the configuration file, the
software will prompt you to choose between saving the file or continuing without saving the file.

1. Save the XML configuration file to your hard drive by going to the File > Save As menu.
2. Go to the DXM > Send XML Configuration to DXM menu.

Figure 2. Status indicator bar

• If the Application Status indicator is red, close and restart the DXM Configuration Tool, unplug and re-plug in the cable
and reconnect the DXM to the software.

• If the Application Status indicator is green, the file upload is complete.
• If the Application Status indicator is gray and the green status bar is in motion, the file transfer is in progress.
After the file transfer is complete, the device reboots and begins running the new configuration.

Upload the XML Configuration File to the Website
To upload an XML configuration file to the website, follow these instructions.

1. At the webserver, select the New Device from the Overview or Device Management page.

2. Select Select File under Update XML.
3. Select the file that was just updated to the DXM and click Save.

After the XML file is loaded into the webserver, the webserver uses the register names and configurations defined in the
configuration file.

4. Click on the Gateway Name link to go to the configured registers to see the values uploaded by the DXM.
The same XML configuration files is now loaded on both the DXM and the Website. After some time, the data should be
seen on the website.

Completing these steps creates continuity between the site created on the website with the DXM used in the field. The DXM pushes
data to the website, which can be viewed at any time.
Refer to the Banner Cloud Data Services Instruction Manual (p/n 178337) to review all the features available for monitoring,
comparing data, and establishing warnings/alarms on the website.
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Final Steps
After the XML configuration file has been uploaded to the DXM and to the BannerCDS website, BannerCDS automatically generates
the dashboards for viewing your sensor data.

1. After the XML configuration file has been uploaded to the DXM, click ENTER on the DXM LCD and go into the Registers
menu.

2. Change CDS Cloud Push from 0 to 1.
Every five minutes, the DXM pushes data from the Vibration Solution to the BannerCDS website dashboards.

AWS IoT Core Quick Start Guide
This guide provides directions for connecting Banner Engineering’s DXM Controller to an AWS IoT Core instead of the Banner CDS.
This guide assumes you have access to an AWS account. If you have not yet done so, set up your AWS account and permissions.
More information is available in the AWS documentation here: Set up your AWS account. The relevant sections are Sign up for an
AWS account, Create a user and grant permissions, and Open the AWS IoT Console.
For more complete information about setting up a DXM1200 Wireless Controller, refer to the instruction manual (p/n 216539).
The DXM requires firmware version 3.3.4 or newer. To download the latest firmware, check the software section of the DXM page on 
www.bannerengineering.com and use the DXM Configuration Software under Tools > Reprogram to load the latest firmware.

Create IoT Resources in AWS IoT Core
1. Go to the AWS IoT Console and create your IoT Resources in the cloud.

You will need to create a Policy and a Thing with associated certificates and keys. Additional guidance for these steps can
be found in the AWS IoT Documentation: Create IoT Resources.

Figure 3. Create your AWS IoT Core certificate

a) On the left menu, go to Secure > Policies to create an AWS IoT Policy that allows your device to interact with AWS IoT.
b) Go to Manage > Things. Click Create and then Create a Single Thing.
c) Download the Certificate, Private Key, and Root CA for your thing. Verify your Certificate is Active.

2. Find your AWS IoT Endpoint.
a) To find the endpoint, go to the AWS IoT console.
b) In the navigation pane, select Settings.
c) The endpoint can be found under Device Data Endpoint. It should look similar to this: xxxxxxxxxxxxxx-

ats.iot.xxxxxxxxx.amazonaws.com.
d) Copy your endpoint and paste it into a safe place for future steps.

Enable AWS IoT Push
To enable AWS IoT pushing, follow these instructions.

1. On your DXM Controller: Click ENTER and go to the Registers menu.
2. Change AWS IoT Push from 0 to 1.
3. Verify CDS Cloud Push is set to zero.
4. On the DXM Configuration Software: With the XML loaded in the configuration software, go to the Settings > Cloud

Services screen.
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Figure 4. Cloud Settings screen for AWS

5. Change the Push method to AWS IoT Core.
6. Enter the Thing Endpoint from the AWS IoT Core Console (also called the Device Data Endpoint).
7. Upload the Certificates and Keys that you downloaded from AWS (Create IoT Resources in AWS IoT Core on page 4).

a) Use the Certificate File Select button to select the Certificate generated from the creation of your Thing.
b) Use the Private Key File Select button to select the Private Key generated from the creation of your Thing.
c) Use the Root CA File Select button to select the Root CA File.

8. (Optional) Modify the ID Name for reference if you are using multiple DXM Controllers.
9. (Optional) Go to the Settings > AWS IoT Core screen.

Figure 5. AWS IoT Core configuration screen

10. (Optional) Create Topic names under Subscribe or Publish. Do not change the Groups and Times.
11. Do NOT adjust the Publish Timers. The DXM Controller pushes to AWS IoT Core every five minutes from the script.
12. (Cellular Connection Only) If you are using a cellular connection instead of Ethernet, navigate to Settings > Ethernet and

set your devices IP Address to Static IP.

Save and Upload the Configuration File
After making any changes to the configuration, you must save the configuration files to your computer, then upload it to the device.
Changes to the XML file are not automatically saved. Save your configuration file before exiting the tool and before sending the XML
file to the device to avoid losing data. If you select DXM > Send XML Configuration to DXM before saving the configuration file, the
software will prompt you to choose between saving the file or continuing without saving the file.

1. Save the XML configuration file to your hard drive by going to the File > Save As menu.
2. Go to the DXM > Send XML Configuration to DXM menu.

Figure 6. Status indicator bar

• If the Application Status indicator is red, close and restart the DXM Configuration Tool, unplug and re-plug in the cable
and reconnect the DXM to the software.

• If the Application Status indicator is green, the file upload is complete.
• If the Application Status indicator is gray and the green status bar is in motion, the file transfer is in progress.
After the file transfer is complete, the device reboots and begins running the new configuration.

Verify the Connection to AWS IoT
Follow these steps to verify you data is connecting with AWS IoT Core.

1. Go to the AWS IoT Core console.
2. Choose Test in the navigation pane.
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3. Select MQTT Test Client.
4. Subscribe to "Expansion Kit," or whatever topics you created to publish in the DXM Configuration Software.

The DXM pushes data every five minutes on Ethernet and every 10 minutes on cellular. The manual data push on the DXM screen
is only for HTTP so you will need to wait 5 minutes to validate the MQTT connection with AWS IoT Core.
For more information or instructions, please follow the instructions for the Wireless Vibration Monitoring Solutions.
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