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Guide Features and Benefits

HIGH SPEED PART COUNTING

Two asynchronous part counting inputs per Node (up to 16 Nodes) with up to 10 kHZ event counting.

STATE INDICATION Monitor and log the current state of both part counting inputs to determine if the input is blocked or
missing parts.
PARTS RATE Calculate parts per minute for both part counting inputs based on user configurable reporting rate.

RATE WARNINGS

User configurable warnings for both part counting inputs based on the parts per minutes.

SMS TEXT/EMAIL ALERTS

Generate SMS text and/or email alerts based on specific events

EFFICIENCY METRICS

Produce efficiency metrics with provided data

CLOUD MONITORING

logging.

Push data to Cloud Webserver or PLC (via LAN or Cellular connection) for remote viewing, alerting, and

Increase production efficiency by monitoring part multiple part counts with to up 16 wireless Performance Nodes. The high-speed
asynchronous totalizing done by the DX80-P16E Node gives the ability to totalize up to 10,000 parts per second. Monitoring the current
state of part counting inputs along with parts per minute rates can be used to establish errors or inefficiencies in the system.

Warnings are generated based on user input and the part rate to alert to conditions that are below standard operating conditions. These
warnings can be used to alert supervisors or production managers about an issue in the system via SMS text messaging, email alerts, or

a remote master light.

Equipment

Model

Description

DX80N9X1SX-P16E OR
DX80N2X1SX-P16E

Sure Cross® Wireless Performance Node P16E; select either a 900 MHz
or 2.4 GHz ISM radio to match the DXM100

Various

Any sourcing (PNP) or sinking (NPN) input.

DXM100-B1C1R1 or
DXM100-B1C1R3

DXM100 Wireless Controller with Cell; select either 900 MHz or 2.4 GHz
ISM radio to match the Q120s and K70s; the C1 model is only necessary
if cellular communiation is needed

A PDF version of this Solutions Guide is available at https://goo.gl/SJ1zBN
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The following guide demonstrates how to bind the wireless DX80-P16E part counting Nodes to the DXM100 and load a preconfigured
XML file and script for 16 Nodes. The XML file only requires some minor modifications to be customized for any site. Follow the
datasheet for the DX80-P16E for proper set up of DIP switches and wiring sensors into the Nodes.

Step 1: Bind the Radios and Assign Device IDs

Binding the DX80-P16E Nodes to the DXM100 establishes a secure connection between them and assigns a specific network address to
each radio within the wireless network.

Apply power to the DXM.

On the DXM: Use the arrow button to select the ISM Radio menu on the DXM’s LCD. Press Enter.

Select Binding and press Enter.

Select Bind to > 1 (the first Node) and press Enter.

On DX80-P16E Node 1: Turn the dials on the face to read 0 on the left and 1 on the right.

Triple-click the binding button (right button on face of radio).

The LEDs on the radio flash four times after it binds to the DXM. This Node is now bound as Node ID 1. Label the Node for
future reference.

7. Onthe DXM: Press Back to return to the main menu.

8. To bind additional DX80-P16Es, select Bind to > X and press Enter.

9. On the second DX80-P16E: Turn the left dial to 0 and the right dial to 2.

10. Triple-click the binding button to start binding Node 2 to its master radio.

ok wnN e

If more DX80-P16Es are being used in the system, continue binding each Node to its master radio until all radios are bound to the DXM
and have been assigned a unique Node ID. On the tenth node, turn the left dial to 1 and the right dial to 0 then increase the right dial
by 1 to get to eleven for the eleventh node and so on up to 16.

When you are finished binding, press Back on the DXM until the DXM returns to the main menu.

Step 2: Run a Site Survey

Verify the wireless connection between your DX80-P16Es and the DXM by running a site survey on the DXM100.
1. On the DXM: Use the arrow buttons to select the ISM Radio menu. Push Enter.
2. Select the Site Survey submenu, and press Enter.
3. Select each Node ID within the system to verify the wireless connection between the Node and the DXM.
4.  When you are finished running the site survey, press Back twice to return to the main menu.
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Step 3: Configure the System

To customize the system to an actual application, make some basic modifications to the template files. There are two files uploaded to
the DXM: the XML file sets the DXM'’s initial configuration and the ScriptBasic file reads the part counts and part counting input states. It
then uses these to calculate the part counting rate, set warnings, establish a reset for each Node, and organize the information in logical
and easy-to-find registers in the DXM.

Loading these files and making adjustments requires using Banner’s DXM Configuration Tool software and the “High Speed Part
Counting” files available using in the links below.

1.
2.
3.

Download the preconfigured files. (https://go0.gl/USfTYy)

Extract the ZIP files into a folder on your computer. Note the location where the files were saved.

Connect the DXM, using the USB cable supplied with the DXM, to a computer containing the DXM Configuration Tool software
or download the software and install it on a computer.

Launch the DXM Configuratin Tool software.

Load the “High Speed Part Counting” XML file by going to File > Load and choosing the configuration files.

Connect the software to the DXM by going to Device > Connection Settings. Select Serial and then select the COM port that
the USB cable is plugged into. Click Connect. If you are unsure which COM port is the correct choice, and multiple appear,
attempt to connect to each one until you are successful.

Upload the “High Speed Part Counting” script file by going to the Settings > Scripting screen. Click Upload Script and select the
file.

Select the uploaded file in the window to the right of the Upload Script button. Click Add Selected to Startup; the DXM will run
this script every time it restarts.

Save the XML file (File > Save). Save the XML file any time the XML has been changed because the tool does not autosave.

Optional Steps: Customize the XML file

1.
2.

Within the DXM Tool, go to the Local Registers > Local Registers in Use screen.

Name the Nodes using the Register Name fields. Because there are 10 registers per Node, copy and paste names for efficiency.
To display the Node counts, current states, parts/min, warnings or connection status on the website, change the Web column
drop-down lists to Read and Cloud Reporting to ON for each Nodes’ information piece (count, current state, parts/min, count,
etc.) that you would like to appear on the website.
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If the Node report rate has been changed from the default of 64 seconds, go to the Local Registers In Use screen. Find the
10th register for each Node, labeled “Node X Report Rate” and change the number underneath the Constant drop-down box
to the number of seconds matching the report rate for that particular Node.

Each Node’s report rate defaults to 64 s. If the DIP switches or UCT tool configured the P16E Node to a different report rate,
the report rate must be changed to match that setting within the DXM Configuration Tool.
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4. Each Node has two warnings based on the parts per minute rates of their counters. Users must set the parts per minute
warning threshold in registers 216 through 247. On the Local Registers In Use screen, find register 216, labeled “Node X
Warning Deltal” and change the number underneath the Constant drop-down box to the desired parts per minute threshold.
When the Node’s first counters’ parts per minute rate is below this threshold, the “Node X Warning 1” field turns on. Users can
set both the WarningDeltal and 2 thresholds for each Node in the system. Leave at the default value of zero if no warning is

desired.

Local Registers

Register Mapping

Register Name

Node 1 WarningDelta 1

Action Rules Node 1 'WamingDelta 2

Node 2 'WarningDelta 1

Scheduler

Node 2 'WarningDelta 2

Constant

L= or Timer

Signed
5
.

None -

Local Register Configuration | Modify Multiple Registers JIRIENENEE AWMV Protocol G

Cloud
Reporting

Constant |

Reqgister View
To display the counts, states, parts/min, and warnings for each Node on '
the website, change the cloud permissions.

a) On the Modify Multiple Registers screen, select Change in the drop-
down list next to Cloud Permissions and Cloud Reporting.

Local Registers
Register Mapping
Action Rules

b) In the drop-down list to the right, select ON for Cloud Reporting and

Read for Cloud Permissions.

c) Set the Starting Register to 1 and the Ending Register to the value SENGEIEE

equal to 10 x Number of Nodes in the system (for example, set the
ending register 160 for 16 Nodes).

d) Click Change Registers on the bottom right of the section.
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) E-mail/SMS on State Transition
E-Mail
Recipient Send Recipient Send
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SMS Recipient 2 | 3 |
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Set up the Ethernet or Cellular Connection

By default, the XML file configures the DXM100 with an Ethernet Push interface with the ability to send emails and push the data
registers to a webserver. The device can also be configured to use a cellular push if the DXM Controller contains a cellular module and
data plan. This section is only necessary if the user wants to receive or display information beyond just the DXM Controller's LCD.

1.

If the DXM will text, email, or push to the cloud webserver, set up the push interface.

a) On the DXM Configuration Tool, go to the Settings > Cloud Services screen.

b) Select the appropriate Push Interface (Ethernet or Cell) from the drop-down list.

Selecting Cell requires a cellular module be installed in the DXM Controller and a wireless plan be set up for sending data.

The Cloud Push Interval determines how often the DXM pushes the - emaiRecipient 1 - Address: [onnsmi com \
current status data to the webserver. By default, this interval is set to Subject: | Light Active |
zero and should not be changed. If data is being pushed to the cloud, Message: | Light s Active |
set the Cloud Push Interval to 00:15:00 (15 minutes). BT A |

» E-mail Recipient 3 - Address: ‘

Set up the email and text messages. SMS works only if the DXM has a

» E-mail Recipient 4 - Address: |

|

|

|

cellular module. Expand the Email Recipients and SMS Recipients t0 | ¢ . recgients - adgsress: | ‘
enter up to 10 email addresses and 10 phone numbers, along with @+ emai Recipient s - adoress: | \
|

|

\

custom message. » E-mail Recipient 7 - Address: |

» E-mail Recipient 8 - Address: ‘

a) Go to the Settings > Mail and Messaging screen.

» E-mail Recipient 9 - Address: ‘

b) All SMTP fields should remain set to their default values, except the , cmai recipient 10 - aderess: | |

Password field. Enter “sxiemaill” into the password field.
c) Click Send SMTP Password. "+ Nams: [SMS Recient 1 \
d) Click Yes when asked to reboot the device. Recipnt.[7easssi2st |

Message: ‘ Light is Activel |

Step 5: Save and Load the XML File

When changes are made to the XML file, save the changes. To apply the changes, load the XML file to the DXM.

1.
2.

Save the file by going to the File > Save menu.
Load the file onto the DXM by going to the Device > Send Configuration to Device menu.

Because of the size of the XML file, the file may take up to three minutes to load. Verifying the file is loading by looking at the
Application Status indicator in the status bar.

If the Application Status indicator is red, close and restart the DXM Configuration Tool, unplug and re-plug in the USB cable and
reconnect the DXM to the software. If the Application Status indicator is green, the file upload is complete. If the Application Status
indicator is yellow, the file transfer is in progress.

Connected 10.10.82.134 Active File: TL70_guide?.xmi S 3 Version: 2.0.41

Connected 10.10.82.134 Active File: TLT0_guide1 xmi Version: 2.0.41

Mot Connected Active File: TL70_guide1 xml

Banner Engineering Corp. ® Minneapolis, MN U.S.A
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Step 6: Push Information to the Cloud

The DXM100 can connect to the web via Ethernet or an internal cell module to push data from the site to display on a website. To
enable this capability for remote monitoring and alarms settings, modify the XML file.

The website for storing and monitoring the system's data is https://data.sensonix.net/.

=

Lo ~NL W

10.
11.
12.

Connect the DXM to a computer with the DXM Configuration Tool software.

Launch the software and connect to the DXM.

Load the saved XML file.

Go to the Settings > Cloud Services screen.

Visit the Sensonix Web Services website (https://data.sensonix.net/) and log into an existing account or register a new account.
Click + New Site and name your site.

Go to the Settings > Sites webpage.

Highlight and copy the Site ID.

On the DXM Configuration Tool: Return to the Settings > Cloud Services screen and paste the copied ID into the Site ID field.
Save the XML file (File > Save).

Upload the file to the DXM (Device > Send Configuration to the Device).

On the Sensonix Web Services website, click Send XML to Web and select the XML file that was just saved and uploaded to the
DXM.

This creates continuity between the site created on the website and the DXM used in the field. The DXM pushes data to the website,
which can be viewed at any time. Refer to the Sensonix Web Services Instruction Manual to review all the features available for
monitoring, comparing data, and establishing warnings/alarms on the website.

SSENSONIX @Dashboard ~  EHistory - SSeilings ~  &Audt - S Sites -
Sites Alarms Tables Backups Users Companies
. Poll Push Register
Edit send XML Get XML site Name site ID LastPush  Method Authentication Interval Interval Estimate
o [CEEINTITE)  High Speed Part 0ac24301-b7c1-4622-9cc2- 18d 6h Ethemet  OFF 00:00:00 00:00:00 0
Counting d27da1004f3a 27m
o =TS  Tank Monitoring c61818c-feB7-400a-810a-44bdi&fcddf  98d dh5m  Cellular  OFF 00:00:00 00-15:00 140160
© [CEETEETEY  Temp Humid 572785f-5236-4d0b-8256- 2d2h45m  Ethemet OFF 00:00:00 00:05:00 1156320

3blaelSecafe

Additional Features
Resetting the Counts

Each Node in the system has a reset register that is available on the face of the DXM’s LCD and via the website. Setting this register to 1
resets all the counts on that particular Node. There is also a Reset All register to reset all Nodes in the system.

Resetting from the DXM

1.

2.
3.
4.

On the DXM: Use the arrows to select Registers. The registers are labeled Reset X (where X is the P16E Node ID you want to
reset). There is a Reset All that resets all statistics for each P16E Node.

Select the appropriate register to reset.
Click Enter.
Change the value to 1 then click Enter three times. The reset register automatically returns to zero after the Node is reset.

Resetting from the Website

1.
2.

Go to the Dashboard > Sites screen.
Click Update Device for the site where the particular Node exists.
The Update pop-up window appears.

Banner Engineering Corp. ¢ Minneapolis, MN U.S.A
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From the Type drop-down list, select Register.

From the Register Name drop-down list, select the Node you want to reset.

Enter 1 into the Value field and click Queue.

Repeat steps 4 and 5 for each Node that needs to be reset or use the Reset All register following steps 4 and 5.

When the next data push occurs, the chosen units reset. The reset registers automatically return to zero after the Node resets.

Creating a Master Light

Local Registers 195—-196 are used to OR each warning independently for all the P16E Nodes (for example, 195 is 1 when ANY Warning 1
in the system is ON).

A master light can be used as one of the 16 Nodes in the system to reflect these OR’d warnings.

1.
2.

On the DXM Configuration Tool software: Go to Register Mapping > Write Rules.

Select Add Write Rule and map two registers starting at 195 to slave ID 1 at the two output registers for the Master Light. The
register number for the master light outputs is N x 16 + 9, where N is the Node ID of the master light. The example shows the
setup for the Master Light on Node ID 10 (10 x 16 + 9 = 169).

REELRAVERY | Write Rules

Local Registers

| Add Write Rule J | Delete Last Rule J

Register Mapping || |l waster Ugn: | wite QR iocal registers rom [JIREERR trouah 195 to stave o [ starting at register [ trovon 170

Action Rules

Configuring Time Stamped Logging

To setup time-stamped logging, follow these steps:

1.

A

Go to the Local Registers > Modify Multiple Registers screen.

Click Reset Form.

From the SD Card Logging drop-down list, select Change.

Select Log 1 in the drop-down list that appears to the right.

Set the Starting Register to 1 and the Ending Register to the value equal to 10 x Number of Nodes in the system (ex. Ending
Register 160 for 16 Nodes). Finally click the Change Registers button on the bottom right portion of the section.

Retrieving a Log File

1.

e W

Connect the DXM to the computer via USB or Ethernet. Connect the DXM Configuration Tool software to the DXM using the
Device > Connection Settings menu.

Go to the Settings > Logging screen.

Click Refresh List.

In the Log File Management window, select the file to save.
Click Save Selected to save the file to a folder on your computer.

Banner Engineering Corp. ® Minneapolis, MN U.S.A
www.bannerengineering.com e Tel: 763.544.3164

P/Nb_4441878 Rev.A 7



High-Speed Part Counting Solutions Guide

Local Register # Description
1+10x(N-1) Part Count #1
2+10x (N-1) Part Count #2
3+10x(N-1) Current State of Counter #1
4+10x(N-1) Current State of Counter #2
5+10x (N-1) Parts per minute #1
Part Counting Node Information
6+10x (N-1) Parts per minute #2
7+10x (N-1) Connection Status
8+10x (N-1) Warning #1
9+10x (N-1) Warning #2
10+10x (N-1) User Configurable Report Rate Constant
ANY Warning Register 195-196 ANY Warning 1 and 2
Node Status 200-215 Node Connection Status
Warning Delta 1 216-247 User Configurable Warning PPM Thresholds
Resets 300-316 Register and Counter Resets
317-332 Node 1-16 Current State 1 Reads
333-348 Node 1-16 Current State 2 Reads
349-364 Node 1-16 Count 1 High Word Reads
Register Reads from Gateways
365-380 Node 1-16 Count 1 Low Word Reads
381-396 Node 1-16 Count 2 High Word Reads
397-412 Node 1-16 Count 2 Low Word Reads
e e 413-428 Node 1-16 Count 1 Timers
429-444 Node 1-16 Count 2 Timers
Prior Counts 445-476 Prior report Counts for establishing PPM

Where N represents the DX80-P16 Node ID Number.
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